Last Comment Bug 682073 - AndroidBridge uses wrong method for calling setClipboardText
: AndroidBridge uses wrong method for calling setClipboardText
Status: VERIFIED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: mozilla7
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
: 682734 (view as bug list)
Depends on:
Blocks: 676341
  Show dependency treegraph
 
Reported: 2011-08-25 13:17 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2011-09-09 15:44 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed
7+


Attachments
patch (1.57 KB, patch)
2011-08-25 13:17 PDT, Mark Finkle (:mfinkle) (use needinfo?)
dougt: review+
asa: approval‑mozilla‑aurora+
asa: approval‑mozilla‑beta+
Details | Diff | Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-08-25 13:17:19 PDT
Created attachment 555820 [details] [diff] [review]
patch

In the AndroidBridge, we use CallStaticObjectMethod when calling setClipboardText and we should use CallStaticVoidMethod:

http://mxr.mozilla.org/mozilla-central/source/widget/src/android/AndroidBridge.cpp#542
http://mxr.mozilla.org/mozilla-central/source/widget/src/android/AndroidBridge.cpp#563
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-25 14:00:30 PDT
http://hg.mozilla.org/mozilla-central/rev/49884897bb5c
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-25 14:02:28 PDT
Comment on attachment 555820 [details] [diff] [review]
patch

Very simple Android-only, low-risk fix. Prevents crashes during tests and possibly an know crasher from the field (bug 676341).
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-08-28 14:16:09 PDT
*** Bug 682734 has been marked as a duplicate of this bug. ***
Comment 5 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-08-29 15:44:27 PDT
Verified: see comment:
https://bugzilla.mozilla.org/show_bug.cgi?id=682734#c4
Comment 6 juan becerra [:juanb] 2011-09-09 15:44:01 PDT
Not something QA is going to track for verification.

Note You need to log in before you can comment on or make changes to this bug.