Last Comment Bug 682088 - Value "browser.display.focus_background_color" should allow for transparent or alternate CSS value
: Value "browser.display.focus_background_color" should allow for transparent o...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86_64 Windows 7
: P3 minor (vote)
: mozilla10
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 13:50 PDT by tomorrow
Modified: 2011-10-12 03:15 PDT (History)
3 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
This should do it (1.50 KB, patch)
2011-08-25 19:59 PDT, Boris Zbarsky [:bz] (still a bit busy)
dbaron: review+
Details | Diff | Splinter Review

Description tomorrow 2011-08-25 13:50:33 PDT
Since bug [url=https://bugzilla.mozilla.org/show_bug.cgi?id=641569]641569[/url] turned out invalid - submitting this instead.
Originally the problem was:

[quote]Setting "browser.display.use_focus_colors" value to "true" causes odd overlay with specific image viewer on many webpages.[/quote]

As per [url=https://bugzilla.mozilla.org/show_bug.cgi?id=641569#c9]Comment 9[/url] on the first bug it would seem that the real issue is that "browser.display.use_focus_colors" causes anything matching ":focus" and anything matching ":focus>font" to have the default focus foreground and background color unless the page styles them otherwise.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-08-25 19:59:33 PDT
Created attachment 555934 [details] [diff] [review]
This should do it
Comment 2 David Baron :dbaron: ⌚️UTC-10 2011-10-10 14:10:32 PDT
Comment on attachment 555934 [details] [diff] [review]
This should do it

I think you should make the function take const nsString&, and make the callers use Preferences::GetString instead of GetCString.

r=dbaron with that, but note that this conflicts with bug 629882
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-10-11 14:16:22 PDT
> I think you should make the function take const nsString&, and make the callers use
> Preferences::GetString instead of GetCString.

Done.

> but note that this conflicts with bug 629882

I'll give ms2ger a heads-up.
Comment 4 tomorrow 2011-10-11 14:18:37 PDT
Im glad this thing is getting somewhere finally.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2011-10-11 14:32:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/073b4ef6933f
Comment 6 Marco Bonardo [::mak] 2011-10-12 03:15:20 PDT
https://hg.mozilla.org/mozilla-central/rev/073b4ef6933f

Note You need to log in before you can comment on or make changes to this bug.