Editing the Feed Location field of Live Bookmark doesn't save changes

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: jorge alves, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I wasn't able to edit a feed's location of a live bookmark. The website in question changed the uri and I tried changing it to the new value without success.

Steps to reproduce (in a clean profile):
1. Go to http://codeinsanity.com/rss.aspx
2. Click "subscribe now" and save the bookmark in the suggested location (bookmarks toolbar)
3. Through the bookmarks toolbar icon, right click livemark and choose "Properties"
4. Change the "Feed location" value to http://www.engadget.com/rss.xml

What happens: the feed location doesn't change. The existing entries are kept and accessing the Properties will show the original value saved in step 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 691362

Comment 2

6 years ago
Confirmed on Windows XP, too. At the very least, probably Windows all. I haven't had a chance to check on my Linux box yet.

Also, from my bug, note that the feed does immediately load the new feed URL, but will go back to the old URL on the next update.

A partial workaround is to load the URL in that Awesome bar, and then subscribe to create a new Live Bookmark. However, this does not allow the user to include username or password (username:password@website.com becomes website.com in the live bookmark.) So feeds that require this information cannot be added.

Comment 3

6 years ago
Confirming on the (precompiled) Linux build of Firefox 7.0.1. I'm going to guess this should be relabeled as ALL.

Note that this is the version downloaded from mozilla.org, not some repository.

Comment 4

6 years ago
Bug is still present in Firefox 8.0.  Can someone please look into this? For all we know, it's trivial to fix.
sorry, this is low low low low priority atm, btw I think the fix here will be to DISALLOW changing the field, for various reasons, that include the fact a lot of devs think we should just drop the livemarks feature. It's much simpler to delete a livemark and recreate a new one on the right website than to manage the feeduri change.

Comment 6

6 years ago
Confirmed on Windows XP with Firefox 8
Duplicate of this bug: 715466

Comment 8

6 years ago
(In reply to Marco Bonardo [:mak] from comment #5)
> sorry, this is low low low low priority atm, btw I think the fix here will
> be to DISALLOW changing the field, for various reasons, that include the
> fact a lot of devs think we should just drop the livemarks feature.

But why? Its a nice feature.

> It's much simpler to delete a livemark and recreate a new one on the right
> website than to manage the feeduri change.

I'm pretty sure this used to work, i.e. changing the feed address. So please fix this regression. And I don't think its "much simpler" the way you described.
it's much simpler from a code point of view, and actually changing a feed uri you are transforming it in something else, so it's more appropriate to make a new one.

Comment 10

6 years ago
This bug has affected me for over a year.  Re-creating the livemark is an acceptable option, but then the fields under livemark properties should not be editable.

Please don't drop livemarks entirely - they're a great feature!

Comment 11

6 years ago
The problem with having to recreate the feed is that there is no way create a feed with login credentials. The feed always uses the same URL as the in the awesome bar. This means that no authenticated feeds can work, when they previously did. 

The only workaround is to run Firefox 6 or lower on the same profile, change the URL in the feed, close, and then run the latest Firefox with that feed. And most problems with Firefox upgrades seem to come from upgrading the profile (as usually recreating the profile fixes any problem), so this is a dangerous workaround.

I personally have just decided not to upgrade past Firefox 6 until this is addressed. Software that upgrades itself shouldn't be taking away features if they want me to continue using updates.
(In reply to Terrell Kelley from comment #11)
> The problem with having to recreate the feed is that there is no way create
> a feed with login credentials. The feed always uses the same URL as the in
> the awesome bar. This means that no authenticated feeds can work, when they
> previously did.

This should be filed apart, the old behavior is just a workaround to a bug in this case.

> The only workaround is to run Firefox 6 or lower on the same profile, change
> the URL in the feed, close, and then run the latest Firefox with that feed.

An add-on may be done easily.
no more possible to edit a feed uri (Well it was also not working)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 613588
Resolution: --- → WONTFIX

Comment 14

6 years ago
> > The only workaround is to run Firefox 6 or lower on the same profile, change
> > the URL in the feed, close, and then run the latest Firefox with that feed.
> 
> An add-on may be done easily.

Clarification: Are you saying an extension may be easily made to allow one to edit the URL of a livemark, and that that would be a better choice than to try to fix the property in plain Firefox?
(In reply to Terrell Kelley from comment #14)
> Clarification: Are you saying an extension may be easily made to allow one
> to edit the URL of a livemark, and that that would be a better choice than
> to try to fix the property in plain Firefox?

exactly, this is not a priority feature.

Comment 16

6 years ago
A good work around is to download SQLite Manager http://code.google.com/p/sqlite-manager/ from the toolbar menu it has a drop down menu to load the places.sqlite from the active profile, then you can go to tables->moz_items_annos and edit the "content" field with anno_attribute_id 4 for the feed URI and 5 for the site URI , you can still edit the title with firefox, but if that ends up breaking, you can go to moz_bookmarks and edit the title there,

Comment 17

6 years ago
Thanks!
(In reply to G.M. Lime from comment #16)
> A good work around is to download SQLite Manager

This is a good guide on how to break your database.
You need to log in before you can comment on or make changes to this bug.