Closed Bug 682148 Opened 9 years ago Closed 9 years ago

Exclude jsshell files when pushing to mirrors

Categories

(Release Engineering :: General, defect, P2)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: nthomas)

References

Details

Attachments

(1 file)

Two linux and one mac files (eg jsshell-linux-i686.zip ) are published to the buildN dir, then rsynced into releases. They should be excluded at the rsync as they aren't targetted at end users. The windows file ends up in unsigned so its OK. The root cause is jsshell packaging not respecting MOZ_PKG_PRETTYNAMES, but we'd have to exclude them even if they were in en-US dirs.
... when downloading for signing and pushing to mirrors.

This affects 7.0b1 and up, and I've cleared up firefox/releases/7.0b{1,2}.
Attachment #555943 - Flags: review?(coop)
Attachment #555943 - Flags: review?(coop) → review+
Comment on attachment 555943 [details] [diff] [review]
[tools] Exclude jsshell*

As checked in:
 http://hg.mozilla.org/build/tools/rev/c6a5b4ecc76f

Slightly tweaked - made them both exclude 'jsshell.*', and in download-exclude.list moved the line up to the other file exclusions.
Attachment #555943 - Flags: checked-in+
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.