Last Comment Bug 682203 - migrate.pl fails at requirements check
: migrate.pl fails at requirements check
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: Bug Import/Export & Moving (show other bugs)
: 4.3
: All All
: -- major (vote)
: Bugzilla 4.0
Assigned To: Marc Schumann [:Wurblzap]
: default-qa
Mentors:
Depends on: 586244
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 21:18 PDT by Marc Schumann [:Wurblzap]
Modified: 2011-08-31 06:26 PDT (History)
2 users (show)
mkanat: approval+
mkanat: approval4.2+
mkanat: approval4.0+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (436 bytes, patch)
2011-08-25 21:18 PDT, Marc Schumann [:Wurblzap]
mkanat: review+
Details | Diff | Review

Description Marc Schumann [:Wurblzap] 2011-08-25 21:18:58 PDT
Created attachment 555947 [details] [diff] [review]
Patch

migrate.pl fails with any migrator, saying "Can't use an undefined value as an ARRAY reference at Bugzilla/Install/Requirements.pm line 545."
Comment 1 Frédéric Buclin 2011-08-26 08:06:35 PDT
Which branches are affected? Is this a regression or not? If yes, due to which bug?
Comment 2 Marc Schumann [:Wurblzap] 2011-08-30 01:12:49 PDT
(In reply to Frédéric Buclin from comment #1)
> Which branches are affected? Is this a regression or not? If yes, due to
> which bug?

This is a regression due to bug 586244. So Bugzilla is affected on 4.0, 4.2 and trunk.
Comment 3 Frédéric Buclin 2011-08-30 07:55:08 PDT
Thanks. This is helpful to have this information when tracking regressions. :)
Comment 4 Marc Schumann [:Wurblzap] 2011-08-31 06:26:53 PDT
4.0:
Committing to: bzr+ssh://wurblzap%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Migrate.pm
Committed revision 7649.

4.2:
Committing to: bzr+ssh://wurblzap%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified Bugzilla/Migrate.pm
Committed revision 7918.

Trunk:
Committing to: bzr+ssh://wurblzap%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Migrate.pm
Committed revision 7945.

Note You need to log in before you can comment on or make changes to this bug.