[Mobile] Rapid Release, Recreate page with Android buttons above desktop buttons

VERIFIED FIXED in 4.2

Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: mcbmoz, Assigned: grace)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Hey Steven,

Can you copy http://www.mozilla.org/en-US/firefox/channel/

to create a new page http://www.mozilla.org/en-US/firefox/channel/android

same content and design, but with the Android buttons above the desktop buttons.

The goal is to increase discoverability for mobile from http://www.mozilla.org/en-US/mobile/ where there is a link on the lower left that says, "see all our channels for mobile" and then it takes the user to the http://www.mozilla.org/en-US/firefox/channel page which has the desktop buttons featured first.

For SEO, page title should read: Mozilla Firefox | Firefox for Android | Download Firefox Aurora & Beta for Mobile

I'll open a separate bug to update the link on http://www.mozilla.org/en-US/mobile/

~cb
(Reporter)

Updated

7 years ago
Depends on: 682354
(Reporter)

Updated

7 years ago
Blocks: 682354
Depends on: 682340
No longer depends on: 682354
(Reporter)

Updated

7 years ago
Blocks: 682340
No longer depends on: 682340

Comment 1

7 years ago
Steven, how much work would it be for you or others in WebDev to maintain an extra page here? I think this has merit in terms of potential SEO or page optimization gains, but don't want to create big extra headaches when there may be other ways of solving.
(In reply to John Slater from comment #1)
> Steven, how much work would it be for you or others in WebDev to maintain an
> extra page here? I think this has merit in terms of potential SEO or page
> optimization gains, but don't want to create big extra headaches when there
> may be other ways of solving.

I was thinking of trying some simple PHP magic in the background to have two variations based on one single file (less duplication). Leave it will be and I'll report back before getting too far into it.

Comment 3

7 years ago
Awesome, thanks!
This is setup in trunk:

http://www-trunk.stage.mozilla.com/en-US/firefox/channel/android/

We still only have one PHP/HTML file behind both /firefox/channel/ and /firefox/channel/android/ - the new URL just flips a switch that changes the order of the buttons. The file is a bit more complex, but it's better than two separate files.

I'd be a bit more concerned about have two very similar versions of this same page stealing sweet Google juice from eachother and of potential confusion from visitors who might somehow find both versions.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: r=94468,94470 b=trunk
(Reporter)

Comment 5

7 years ago
(In reply to Steven Garrity from comment #4)
> This is setup in trunk:
> 
> http://www-trunk.stage.mozilla.com/en-US/firefox/channel/android/
> 
> We still only have one PHP/HTML file behind both /firefox/channel/ and
> /firefox/channel/android/ - the new URL just flips a switch that changes the
> order of the buttons. The file is a bit more complex, but it's better than
> two separate files.
> 
> I'd be a bit more concerned about have two very similar versions of this
> same page stealing sweet Google juice from eachother and of potential
> confusion from visitors who might somehow find both versions.

Steven,

You make excellent points, we're actually redesigning this experience tip-to-tail and addressing these concerns. For this short term fix a few things:

*Can you update the drop-down navigation under Mobile, so that this page appears for users who click on "Future Releases"

Grace/Jaclyn,

Can you help us improve the experience for users, coming in from search engines, so that the copy includes the terms: mobile and Android?

*Headline: Future of Firefox (for Mobile)
*Copy under the bullet points

This is a short-term patch, while the new experience is designed (super excited for that to come together!)

~cb
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

7 years ago
so if we are changing the headline to a more mobile or android focus... we have to remove the desktop buttons. 

if we decide to keep the desktop buttons, I dont think we should make changes in the copy ;) 

and to chrissie's point, we are in the process of revamping this page (including content to increase SEO.

suggestions for copy changes would be:
+1 Chrissie's Headline: Future of Firefox for Mobile 
or 
Description: Download Firefox Aurora or Firefox Beta for Android and test the build that’s right for you.

also adding matej if he has other suggestions.

Comment 7

7 years ago
If this is specifically for Android users, should the download buttons say "Download Firefox Aurora for Android" and "Download Firefox Beta for Android" instead of "...for Mobile?"

As for the rest of the copy, here's what I would suggest:

[HEADLINE]

The Future of
FIREFOX FOR MOBILE

[COPY]

Download and test the Android build that’s right for you, and sign up for a channel newsletter to stay in the loop.
As briefly discussed in IRC, summarized here for continuity:

This bug started with a flipping of the order of the buttons, but with separate headline/intro copy, it's more like a standalone page now. I was a bit concerned about introducing a new page/URL into the world when a redesign is pending.

That said, Chrissie shared wireframes of the pending redesign and it seems that this single page is branching out into six pages (Channels overview, Aurora, Beta, and then the same three for Mobile).

Can we work out the URL scheme for these pages so this new page ends up in the right place and we don't end up splitting external links and search engine results across multiple URLs?
(In reply to Steven Garrity from comment #8)
> Can we work out the URL scheme for these pages so this new page ends up in
> the right place and we don't end up splitting external links and search
> engine results across multiple URLs?

Chrissie?

Updated

7 years ago
Blocks: 684378
Bumping to 3.10 - this is waiting on further info.
Target Milestone: 3.9 → 3.10
Chrissie, is there a separate bug for sorting out these URLs? Can I reassign this to you in the meantime? Still waiting on a reply to comment #8.
Target Milestone: 3.10 → 3.11
(Reporter)

Comment 12

6 years ago
(In reply to Steven Garrity from comment #11)
> Chrissie, is there a separate bug for sorting out these URLs? Can I reassign
> this to you in the meantime? Still waiting on a reply to comment #8.

Yep, reassign to me.

In the meantime, Grace, here are my recommendations:

In the URL, use the brand name and the mobile platform name, which will allow us to optimize for mobile browsing, but add pages by platform and ensure the right search experience and likely get more highly qualified users.

Can you confirm that we can proceed with:

Main landing page: http://www.mozilla.org/en-US/firefox/releases (currently is http://www.mozilla.org/en-US/firefox/channel/)

Aurora desktop product page: http://www.mozilla.org/en-US/firefox/aurora
Aurora Android product page: http://www.mozilla.org/en-US/firefox/aurora/android

Beta desktop product page: http://www.mozilla.org/en-US/firefox/beta
Beta Android product page: http://www.mozilla.org/en-US/beta/android

GA desktop: http://www.mozilla.org/en-US/firefox/features/ (stays the same as it is now)
GA mobile: http://www.mozilla.org/en-US/mobile/ (stays the same as it is now)
(Reporter)

Comment 13

6 years ago
Grace assigning to you.

Can you please approve URL structure in comment 12.

This will help lay the seo foundation work for when the future rapid release pages are ready for launch.
Assignee: steven → gjimenez
Bringing this conversation back from email to bugzilla. Chrissie suggested (and there has been general agreement on) these URLs:

> Main landing page: http://www.mozilla.org/en-US/firefox/releases (currently is http://www.mozilla.org/en-US/firefox/channel/)
> Aurora desktop product page: http://www.mozilla.org/en-US/firefox/aurora
> Aurora Android product page: http://www.mozilla.org/en-US/firefox/aurora/android
> Beta desktop product page: http://www.mozilla.org/en-US/firefox/beta
> Beta Android product page: http://www.mozilla.org/en-US/beta/android
> GA desktop: http://www.mozilla.org/en-US/firefox/features/ (stays the same as it is now)
> GA mobile: http://www.mozilla.org/en-US/mobile/ (stays the same as it is now)

The http://mozilla.org/en-US/firefox/releases URL is already in use (albeit by a seldom-used page). Should this page be moved, dropped, replaced?

Why are the /beta/ URLs at the root level, while the /aurora/ pages are under /firefox/ - is this distinction intentional?

This list is missing a mobile version of the main rapid release landing page - would that be /mobile/releases/ ?

Also, are there any long term plans for /mobile/ to move under /firefox/mobile/? It seems it does belong there now that all of these pages live within the larger .org site.
(In reply to Steven Garrity from comment #14)
> Bringing this conversation back from email to bugzilla. Chrissie suggested
> (and there has been general agreement on) these URLs:
> 
> > Main landing page: http://www.mozilla.org/en-US/firefox/releases (currently is http://www.mozilla.org/en-US/firefox/channel/)
> > Aurora desktop product page: http://www.mozilla.org/en-US/firefox/aurora
> > Aurora Android product page: http://www.mozilla.org/en-US/firefox/aurora/android
> > Beta desktop product page: http://www.mozilla.org/en-US/firefox/beta
> > Beta Android product page: http://www.mozilla.org/en-US/beta/android
> > GA desktop: http://www.mozilla.org/en-US/firefox/features/ (stays the same as it is now)
> > GA mobile: http://www.mozilla.org/en-US/mobile/ (stays the same as it is now)
> 
> The http://mozilla.org/en-US/firefox/releases URL is already in use (albeit
> by a seldom-used page). Should this page be moved, dropped, replaced?

This should be kept for now. 
> 
> Why are the /beta/ URLs at the root level, while the /aurora/ pages are
> under /firefox/ - is this distinction intentional?

Looks like a mistake. They should have the same structure across the board.
 
> This list is missing a mobile version of the main rapid release landing page
> - would that be /mobile/releases/ ?

That seems to be what the structure would be based on the above.  We'll wait for Chrissie on this one too. 
> 
> Also, are there any long term plans for /mobile/ to move under
> /firefox/mobile/? It seems it does belong there now that all of these pages
> live within the larger .org site.

Chrissie should answer that when she gets back, but that seems right to me.

Comment 16

6 years ago
(In reply to Laura Mesa [:lmesa] from comment #15)
> (In reply to Steven Garrity from comment #14)

> > The http://mozilla.org/en-US/firefox/releases URL is already in use (albeit
> > by a seldom-used page). Should this page be moved, dropped, replaced?
> 
> This should be kept for now. 

LoMo - /releases is meant to be the main landing page, how about moving the content that's there to a more accurate /releasenotes and using /releases as the main landing page as proposed?
(In reply to Laura Forrest from comment #16)
> (In reply to Laura Mesa [:lmesa] from comment #15)
> > (In reply to Steven Garrity from comment #14)
> 
> > > The http://mozilla.org/en-US/firefox/releases URL is already in use (albeit
> > > by a seldom-used page). Should this page be moved, dropped, replaced?
> > 
> > This should be kept for now. 
> 
> LoMo - /releases is meant to be the main landing page, how about moving the
> content that's there to a more accurate /releasenotes and using /releases as
> the main landing page as proposed?

Sorry-totally missed that. Yes, lets move to /releasenotes.

Updated

6 years ago
Target Milestone: 3.11 → 3.12

Updated

6 years ago
Target Milestone: 3.12 → 4.0

Updated

6 years ago
Target Milestone: 4.0 → 4.1
Finally getting back to this. Chrissie, can you read through the thread and address the out-standing issues. Particularly, the wording issues brought up in comments #5, #6, & #7. 

I'm mostly wonder about this point from Grace:

(In reply to Grace Jimenez :grace from comment #6)
> so if we are changing the headline to a more mobile or android focus... we
> have to remove the desktop buttons. 
> if we decide to keep the desktop buttons, I dont think we should make
> changes in the copy ;)
(Reporter)

Comment 19

6 years ago
Steven,

Matej's copy in comment 7 is the copy we should use.

Grace makes a great point, but much like we do over on desktop - the page is focused on desktop, but we do have the mobile buttons as an added value. This is the same concept, just flipping the experience for mobile.

The goal here isn't to have a perfect page (yet), but to establish a presence for users and namely search engines. Right now, we're currently not in the top 50 results on any search engine for mobile browsing.
Ok, this page is now all set in trunk at: http://www-dev.allizom.org/en-US/firefox/channel/android/

Please review/QA.

The main channel page (http://www-dev.allizom.org/en-US/firefox/channel/) shares some code, so it should be run through QA as well.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: r=94468,94470 b=trunk → r=94468,94470,96270,96319 b=trunk
Duplicate of this bug: 691153
Target Milestone: 4.1 → 4.2
qa-verified-trunk http://www-dev.allizom.org/en-US/firefox/channel/android/
Keywords: qawanted
pushed to production r96529
Whiteboard: r=94468,94470,96270,96319 b=trunk
verified fixed http://www.mozilla.org/en-US/firefox/channel/android/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.