Last Comment Bug 682506 - Upgrade ANGLE to r740
: Upgrade ANGLE to r740
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla9
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 21:42 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-08-31 02:13 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Benoit Jacob [:bjacob] (mostly away) 2011-08-26 21:42:08 PDT
On try:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=cfc2855e3356

Also, ANGLE is now able to output GLES shader code, instead of just plain GLSL. Since we had to explicitly choose (ShConstructCompiler takes a new mandatory argument) this patch has a 1-line change in WebGLContextGL.cpp to choose GLES SL on GLES and desktop GLSL on desktop GL.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-08-27 11:00:35 PDT
Had to back out ANGLE r738 as it doesn't seem quite ready yet, see ANGLE bug 201.

New try:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=89a1deef651b
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-08-30 13:09:04 PDT
That was green.

ANGLE r740 should fix the regression from ANGLE r738. New try:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=c10d8ce9659a
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-08-30 16:55:10 PDT
Green.

Inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/66d6a27e3581
Comment 4 Marco Bonardo [::mak] 2011-08-31 02:13:05 PDT
http://hg.mozilla.org/mozilla-central/rev/66d6a27e3581

Note You need to log in before you can comment on or make changes to this bug.