Closed Bug 682538 Opened 9 years ago Closed 8 years ago

SIGSEGV probably caused by libvoikko.

Categories

(Firefox :: General, defect, critical)

7 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: attekett, Unassigned)

Details

(Keywords: crash, Whiteboard: [closeme 2012-01-21])

Crash Data

Attachments

(2 files)

Attached file repro-file
Tested on Ubuntu 11.04 x86_64 Firefox 7.0~b1

https://crash-stats.mozilla.com/report/index/bp-c0b28c1a-b570-4502-b659-08b6a2110827

Open attachment file on Firefox to reproduce crash.

I was unable to reproduce on Valgrind or GDB so no log to attach.
Attachment #556245 - Attachment mime type: text/plain → text/html
Crash Signature: [@ libc-2.13.so@0x7a706 ]
Keywords: crash
Seems to be resolved in 7.0~b2. Atleast I cannot reproduce crash after update.
https://crash-stats.mozilla.com/report/index/bp-aa6be1a5-9d5f-41e3-842b-c1fae2110827

Seems to still exists. just the way to reproduce the problem changed. I will add new repro-file as soon as possible.
Attached file new reproduce file
I can confirm this bug.

Seems to me that removing mozvoikko 1.1.9 and installing new test version (mozvoikko2.xpi) from Andris Pavenis:

http://ap1.pp.fi/mozilla/mozvoikko2/

solves this crash

Some notices (in Finnish) in Mozilla.fi
http://www.mozilla.fi/keskustelu/viewtopic.php?p=48021#p48021
Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110914 Firefox/9.0a1

Works for me on Firefox 7 beta 5 and Nightly. I used the repro file from comment 3.

Can you still reproduce using the file on the latest Beta or on Firefox Nightly?
Have you tried with a clean profile?
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Atte?

(In reply to Virgil Dicu [QA] from comment #5)
> Works for me on Firefox 7 beta 5 and Nightly. I used the repro file from
> comment 3.
> 
> Can you still reproduce using the file on the latest Beta or on Firefox
> Nightly?
> Have you tried with a clean profile?
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Whiteboard: [closeme 2012-01-21]
Sorry. Didn't notice the question. Doesn't reproduce on my current Nightly, Firefox 8.0.1 or 9.0.1
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.