Last Comment Bug 682615 - OOM crash in BasicPlanarYCbCrImage::SetData
: OOM crash in BasicPlanarYCbCrImage::SetData
Status: RESOLVED FIXED
: crash, topcrash
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Linux
: -- critical (vote)
: mozilla9
Assigned To: Matt Woodrow (:mattwoodrow) (PTO until 27 June)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-27 14:31 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2011-08-31 02:16 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use fallible memory allocation for BasicPlanarYCbCrImage (950 bytes, patch)
2011-08-27 14:42 PDT, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
roc: review+
Details | Diff | Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-08-27 14:31:35 PDT
This is the 6th top crasher on Firefox 8.0a2 on Linux with 4 crashes last week on 2 different machines/distros, including one on Ubuntu.

https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A8.0a2&platform=linux&query_search=signature&query_type=contains&reason_type=contains&date=&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=mozalloc_abort%20%7C%20mozalloc_handle_oom%20%7C%20moz_xmalloc

Here's one crash link:

https://crash-stats.mozilla.com/report/index/f84db231-bb1b-4982-a451-193212110826

Video playback is a memory-intensive process. Should we use a fallible memory allocator there?
Comment 1 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-08-27 14:42:24 PDT
Created attachment 556309 [details] [diff] [review]
Use fallible memory allocation for BasicPlanarYCbCrImage
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-08-27 14:49:54 PDT
Have you checked that memory allocated by AllocateBuffer can be freed in the same way was memory allocated by operator new[]?
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-08-28 14:20:40 PDT
Comment on attachment 556309 [details] [diff] [review]
Use fallible memory allocation for BasicPlanarYCbCrImage

Review of attachment 556309 [details] [diff] [review]:
-----------------------------------------------------------------

It can be freed via delete[], although that should probably be documented in ImageLayer.h.
Comment 4 Robert Kaiser (not working on stability any more) 2011-08-29 06:15:05 PDT
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=mozalloc_abort%20|%20mozalloc_handle_oom%20|%20moz_xmalloc says this happens across multiple Firefox versions on Linux and Mac, and bug 636318 as well as bug 682595 are related or dupes.
Comment 5 Robert Kaiser (not working on stability any more) 2011-08-29 06:31:38 PDT
*** Bug 682595 has been marked as a duplicate of this bug. ***
Comment 6 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-08-30 19:13:28 PDT
Landed on inbound:

http://hg.mozilla.org/integration/mozilla-inbound/rev/62b958e49c66
Comment 7 Marco Bonardo [::mak] 2011-08-31 02:16:33 PDT
http://hg.mozilla.org/mozilla-central/rev/62b958e49c66

Note You need to log in before you can comment on or make changes to this bug.