Closed Bug 682694 Opened 10 years ago Closed 6 years ago

GCLI JS autocomplete should be smarter

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jwalker, Unassigned)

References

Details

We should be doing the following things:
- case insensitive matching
- typo fixing (soundex?)
- partial matches
- highlighting matched sections
- sorting according to match quality
Depends on: 672733
Another way to fix typos would be with a spell checker like this:

https://github.com/past/speller

Generating the word file from the available keywords, variables, etc. should be pretty straightforward.
Thanks Panos - I was trying to remember that - I knew it had popped up before.
Duplicate of this bug: 701343
Moving GCLI bugs to Developer Tools: Console. Filter on 'baked beans are off'.
Component: Developer Tools → Developer Tools: Console
Triage. Filter on PEGASUS.
Priority: -- → P3
No longer blocks: GCLI-FUTURE
New component triage. Filter on "Lobster Thermidor aux crevettes with a Mornay sauce"
Component: Developer Tools: Console → Developer Tools: Graphic Commandline and Toolbar
Blocks: 874786
Resetting priorities because these P* levels are very out of date.
Sorry for the bug spam. Filter on Lobster Thermidor
Priority: P3 → --
Triage. Filter on Lobster Thermidor.

Some of this is done, the rest is not worth keeping on file.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer depends on: 672733
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.