Closed Bug 682731 Opened 8 years ago Closed 8 years ago

search of local folders not regenerating missing summary files

Categories

(MailNews Core :: Search, defect)

x86_64
Windows 7
defect
Not set

Tracking

(thunderbird8 fixed)

RESOLVED FIXED
Thunderbird 9.0
Tracking Status
thunderbird8 --- fixed

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

Attached patch proposed fixSplinter Review
It used to be that searching local folders would cause a reparse of the local folder db if the summary file was missing. Now, it only seems to reparse if the summary file is out of date, but doesn't handle the missing case.
Attachment #556420 - Flags: review?(neil)
Blocks: 682721
A one-line fix is pretty nifty. Is there any way to discover how/when this regression happened?

Since I thoroughly described this problem for 6.0 with screenshot attachments in bug 682588, and made a separate bug 682721 for 3.1.12, I've added a dependency pointing here.
Blocks: 682588
Attachment #556420 - Flags: review?(neil) → review+
fixed on trunk - http://hg.mozilla.org/comm-central/rev/2497b8367fb9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Comment on attachment 556420 [details] [diff] [review]
proposed fix

safe fix for what should be a rare situation...
Attachment #556420 - Flags: approval-comm-aurora?
What will it take to get this into 3.1.13 with the DigiNotar deprecation (bug 682956)?
(In reply to william.allen.simpson from comment #4)
> What will it take to get this into 3.1.13 with the DigiNotar deprecation
> (bug 682956)?

That's not happening. We're not going to do anything to slow down the DigiNotar fix release.
No longer blocks: 682721
Duplicate of this bug: 682721
Attachment #556420 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.