Last Comment Bug 682794 - autoconf.mk is not rebuilt when autoconf.mk.in changes
: autoconf.mk is not rebuilt when autoconf.mk.in changes
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 676252
  Show dependency treegraph
 
Reported: 2011-08-29 00:36 PDT by Mike Hommey [:glandium]
Modified: 2011-08-31 08:05 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Refresh autoconf.mk when autoconf.mk.in is modified (2.07 KB, patch)
2011-08-29 00:49 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-08-29 00:36:47 PDT
When I landed bug 676252, I got failures on OSX and Windows builds because they were getting an empty string for OBJ_SUFFIX. The only reason I can think of to explain that is if autoconf.mk was not refreshed.

In fact, the backout of bug 676252 failed on platforms where the bug 676252 landing worked because of that: autoconf.mk was still containing the $(error) value, while config/config.mk was not resetting it anymore, leading to an error.
Comment 1 Mike Hommey [:glandium] 2011-08-29 00:41:30 PDT
There is a rule in client.mk to refresh autoconf.mk, but nothing depends on it. Also, nothing takes care of js/src/config/autoconf.mk.
I think autoconf.mk should be refreshed, like Makefiles, from rules.mk.
Comment 2 Mike Hommey [:glandium] 2011-08-29 00:49:14 PDT
Created attachment 556486 [details] [diff] [review]
Refresh autoconf.mk when autoconf.mk.in is modified
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-29 04:42:16 PDT
Comment on attachment 556486 [details] [diff] [review]
Refresh autoconf.mk when autoconf.mk.in is modified

This scares me a little bit, but ok. r=me
Comment 4 Mike Hommey [:glandium] 2011-08-29 04:52:15 PDT
http://hg.mozilla.org/projects/build-system/rev/3aa52a5e7e5c
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-31 08:04:37 PDT
http://hg.mozilla.org/mozilla-central/rev/3aa52a5e7e5c

Note You need to log in before you can comment on or make changes to this bug.