Last Comment Bug 682871 - make package fails when $(MOZILLA_DIR) is a relative path
: make package fails when $(MOZILLA_DIR) is a relative path
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: mozilla9
Assigned To: Jason Orendorff [:jorendorff]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-29 09:47 PDT by Jason Orendorff [:jorendorff]
Modified: 2011-09-04 17:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.05 KB, patch)
2011-08-29 10:20 PDT, Jason Orendorff [:jorendorff]
bugspam.Callek: review+
ted: superreview+
Details | Diff | Splinter Review

Description Jason Orendorff [:jorendorff] 2011-08-29 09:47:14 PDT

    
Comment 1 Jason Orendorff [:jorendorff] 2011-08-29 10:20:14 PDT
Created attachment 556594 [details] [diff] [review]
fix

Ted suggested this fix and it WFM.
Comment 2 Justin Wood (:Callek) 2011-08-29 11:44:28 PDT
Comment on attachment 556594 [details] [diff] [review]
fix

That looks right, given the number of places we call GENERATE_CACHE and what this is doing.
Comment 3 Jason Orendorff [:jorendorff] 2011-08-29 12:15:12 PDT
Oh, but you know what? We should find out if xpcshell is actually exiting with a nonzero exit code in this case, and if so, fix the makefile to notice the error. (It is a kind of complicated command with some () and some && and some ; up in there.)

If it's xpcshell's fault, we should fix that, separate bug I guess.
Comment 4 Jason Orendorff [:jorendorff] 2011-08-29 13:49:49 PDT
(In reply to Jason Orendorff [:jorendorff] from comment #3)
> Oh, but you know what? We should find out if xpcshell is actually exiting
> with a nonzero exit code in this case, and if so, fix the makefile to notice
> the error. (It is a kind of complicated command with some () and some && and
> some ; up in there.)

By "we", of course, I mean "y'all".

I checked and it looks like xpcshell's exit code is 3 in this case, so I guess a Makefile fix would be the thing.
Comment 5 Jason Orendorff [:jorendorff] 2011-09-02 16:24:18 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/7509ecc14e9e
Comment 6 Ed Morley [:emorley] 2011-09-04 17:01:03 PDT
http://hg.mozilla.org/mozilla-central/rev/7509ecc14e9e

Note You need to log in before you can comment on or make changes to this bug.