Can't unsubscribe from newsgroup if its name has a non-ASCII character in it

VERIFIED FIXED

Status

VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: avm, Assigned: hwaara)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Type in the browser locator field news url and end it with "\"
 (e.g news://news.mozilla.org/netscape.public.mozilla.xpcom\)
 -Messenger window will be opened.
2. Try to unsubscribe from this group - you can do it only via "del" key
3. Restart and note that this news group is still present in list

Reproduced under Intel Solaris 2.7.
Build:Mozilla/5.0 (X11; U; SunOS 5.7 i86pc; en-US; m18) Gecko/20010123 
Netscape6/6.0
Tag info as follows: [tag: -r Netscape_6_0_OEM_BRANCH -D "01/19/2001 10:00:00"  
         PSM: 1.4 (PSM_1_4_N6) & NSS 3.1 (NSS_3_1_RTM tag)
which type of IMAP server?

Netscape_6_0_OEM_BRANCH?  try a trunk build, a lot of subscribe changes have
happened on the trunk.
zoinks, this isn't even imap.  I need to wake up.

accepting
Status: NEW → ASSIGNED
QA Contact: esther → stephend
(Assignee)

Comment 3

17 years ago
You can trigger this if your newsgroup's name has *any* non-ascii character.
Summary: Can't unsubscribe from news group, if it name was typematched with "\" → Can't unsubscribe from news group, if its name has a non-ascii character in it
(Assignee)

Comment 4

17 years ago
Created attachment 57379 [details] [diff] [review]
Patch -uw

The problem was that we were passing an unescaped string to
nsMsgFolder::FindSubFolder() which then was failing and gave us a bogus folder
that made it so the function that actually deletes our folder failed
(nsMsgFolder::PropagateDelete).

The fix is to escape the newsgroup name, and to add a comment above
FindSubFolder() so no one else will make the same mistake in the future.
(Assignee)

Comment 5

17 years ago
Reassign to self.
Assignee: sspitzer → hwaara
Status: ASSIGNED → NEW
Created attachment 57682 [details] [diff] [review]
updated patch

hwaara's fix was correct.  

this just fixes the comment and some style / white space issues.
Attachment #57379 - Attachment is obsolete: true
the comment to FindSubFolder() is not correct.

how news chooses to handle names (escaping them to handle non-ASCII) is not 
true for all callers of FindSubFolder.
Status: NEW → ASSIGNED
to test, exit, add håkan to your newsrc file for news.mozilla.org and start up 
and expand news.mozilla.org
Summary: Can't unsubscribe from news group, if its name has a non-ascii character in it → Can't unsubscribe from newsgroup if its name has a non-ASCII character in it
fix checked in for hwaara.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Mac and win32 are fine, just waiting on bug 110158 before I mark this verified.
Depends on: 110158
OS: Solaris → All
Hardware: Sun → All
Verified FIXED:

Windows 2K - 2001-11-16-03
Mac OS 10.1 - 2001-11-16-09
RedHat 7.2 - 2001-16-06
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.