The default bug view has changed. See this FAQ.

Content area of remote desktop pane displays area of previously viewed page

VERIFIED FIXED in Firefox 9

Status

Fennec Graveyard
General
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({regression})

Trunk
Firefox 9
ARM
Android
regression

Details

(Whiteboard: [inbound])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 556828 [details]
Nightly (08/30)

Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110830 Firefox/9.0a1 Fennec/9.0a1

Currently on trunk when viewing the remote desktop pane, you will see an area of the previously viewed page (behind the Sync related dialog).

Not reproducible on Aurora (8.0a2 [08-30]) nor Beta (7.0-build2).

Regression from bug 681356?

STR:
1. Visit a website, i.e., (mozilla.com)
2. Tap the navigation-bar, tap the 'Desktop' pane
(Reporter)

Updated

6 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM
(Reporter)

Comment 1

6 years ago
Related? bug 668760
(Assignee)

Updated

6 years ago
Assignee: nobody → wjohnston
(Reporter)

Updated

6 years ago
Duplicate of this bug: 684463
(Reporter)

Updated

6 years ago
Duplicate of this bug: 683185

Comment 4

6 years ago
needs priority.  still reproducing on 09162011 nightly
tracking-fennec: --- → ?
status-firefox6: --- → affected
status-firefox7: --- → affected
status-firefox8: --- → affected
Priority: -- → P2

Comment 5

6 years ago
looks like its on nightly only.  not reproducing for me on aurora and beyond.
status-firefox6: affected → unaffected
status-firefox7: affected → unaffected
status-firefox8: affected → unaffected
status-firefox9: --- → affected
tracking-fennec: ? → 9+
(Assignee)

Comment 6

6 years ago
Created attachment 561944 [details] [diff] [review]
Patch
Attachment #561944 - Flags: review?(mark.finkle)
Comment on attachment 561944 [details] [diff] [review]
Patch

Froyo is not affected?
Attachment #561944 - Flags: review?(mark.finkle) → review+
Drive-by review comment: In the Froyo theme we put a background on the .autocomplete-items class instead.
(Assignee)

Comment 9

6 years ago
Created attachment 562065 [details] [diff] [review]
Patch v2

I should have looked at this harder. We're trying to show a message in this case, but the sync message pane isn't themed on honeycomb or gingerbread. This just copies over the theme code from Froyo.

I'll attach some screenshots I took on desktop or both. In both, I've forced the theme to show a message by adding an else statement if "engine" does not exist here:

http://mxr.mozilla.org/mozilla-central/source/mobile/chrome/content/bindings.xml#1412

we should show a message in that case and probably show a button(/link?) ("Set up sync", or if sync is set up but disabled "Enable sync"). I'll file a separate bug for that.
Attachment #561944 - Attachment is obsolete: true
Attachment #562065 - Flags: review?(mbrubeck)
(Assignee)

Comment 10

6 years ago
Created attachment 562066 [details]
Honeycomb screenshot
(Assignee)

Comment 11

6 years ago
Created attachment 562067 [details]
Gingerbread screenshot
Attachment #562065 - Flags: review?(mbrubeck) → review+
Duplicate of this bug: 688758
(Assignee)

Comment 13

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/df408aabbd90
Whiteboard: [inbound]
https://hg.mozilla.org/mozilla-central/rev/df408aabbd90
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
(Reporter)

Comment 15

6 years ago
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110925 Firefox/9.0a1 Fennec/9.0a1
Status: RESOLVED → VERIFIED
status-firefox9: affected → fixed
(Reporter)

Updated

5 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.