Firefox 6 doesn't interpret wpad.dat file correctly on Windows 7 multihomed computer

RESOLVED DUPLICATE of bug 347307

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 347307
7 years ago
6 years ago

People

(Reporter: Federico Giampietri, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.215 Safari/535.1

Steps to reproduce:

My wpad.dat assigns a proxy depending of what network the client belongs to..
I have several virtual machines that have Windows 7 , Firefox 5 ,6a nd two NICs and they ask for wpad.dat correctly but the proxy is not assigned correctly because under Windows 7 Firfox is not passing for the part of the code on wpad.dat that should assign the proxy address. This works fine on Windows XP and also Win vista and 7 with IE. 

Part of the code that should assign the proxy for this case:
if (isInNet(myIpAddress(), "172.168.98.0", "255.255.254.0") || isInNet(myIpAddress(), "172.168.96.0", "255.255.254.0") ){
		return "PROXY 172.168.99.252:8080";}
	
	if (isInNet(myIpAddress(), "10.64.88.0", "255.255.254.0") || isInNet(myIpAddress(), "10.64.86.0", "255.255.254.0") ){
		return "PROXY 172.168.99.252:8080";}


Actual results:

It could be that isInNet function isn't working as expected on Windows 7 multihomed machine? 
Best Regards
Not that I can reproduce this due to Lack of the Enviroment, but if this worked in past Firefox Versions, you might want to help by providing a Regression Range against mozilla-central using http://harthur.github.com/mozregression/
(Reporter)

Comment 2

7 years ago
I can confirm that this doesn't work also for a Windows 7 with only one NIC. I looks like Firefox on Windows 7 doesn't like the isInNet or myIpAddress functions: 

Part of the code that should assign the proxy for this case:
if (isInNet(myIpAddress(), "172.168.98.0", "255.255.254.0") || isInNet(myIpAddress(), "172.168.96.0", "255.255.254.0") ){
		return "PROXY 172.168.99.252:8080";}
	
if (isInNet(myIpAddress(), "10.64.88.0", "255.255.254.0") || isInNet(myIpAddress(), "10.64.86.0", "255.255.254.0") ){
		return "PROXY 172.168.99.252:8080";}
Please add a "alert(myIpAddress()); " and look in the Firefox error console which IP is reported.
It's known that myIpAddress often returns unwanted IPs such as the local link IPv6 in my case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347307
You need to log in before you can comment on or make changes to this bug.