If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

handle new cases of JSTRACE in a more graceful fashion

RESOLVED DUPLICATE of bug 674251

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 674251
6 years ago
6 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Twice in the past couple of weeks we've had JSTRACE things added, for JS scripts and type inference, without cases being added to JS_PrintTraceThingInfo, which causes JS_DumpHeap to assert.  We should add some kind of test to check for that, either some kind of JS_assert, or a crash test that calls JS_DumpHeap.  I guess that since this is just debug logging code, so we could alternatively just fail more quietly.  But that sounds bad.

Comment 1

6 years ago
As my patch for the bug 674251 has the same problems with JSTRACE_SCRIPT I am going to update the patch there and add JSGCTraceKind enum. Then at least with GCC we get warnings about missing labels.
(Reporter)

Comment 2

6 years ago
Yeah, that sounds like a much better fix than anything I had thought of!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 674251
You need to log in before you can comment on or make changes to this bug.