Last Comment Bug 683403 - rm JS_LONE_INTERPRET
: rm JS_LONE_INTERPRET
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Luke Wagner [:luke]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 18:04 PDT by Luke Wagner [:luke]
Modified: 2011-09-02 12:48 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm JS_LONE_INTERPRET (7.83 KB, patch)
2011-08-30 18:04 PDT, Luke Wagner [:luke]
igor: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2011-08-30 18:04:50 PDT
Created attachment 557052 [details] [diff] [review]
rm JS_LONE_INTERPRET

/*
 * JS_LONE_INTERPRET indicates that the compiler should see just the code for
 * the js_Interpret function when compiling jsinterp.cpp. The rest of the code
 * from the file should be visible only when compiling jsinvoke.cpp. It allows
 * platform builds to optimize selectively js_Interpret when the granularity
 * of the optimizations with the given compiler is a compilation unit.
 */

A GCC shell build on SS/V8 and a Win32 Talos build on SS/Dromaeo/Ts/etc does not show any speedup from JS_LONE_INTERPRET.  Since this is really pretty strange and I have seen it frustrate several newcomers ("why can't Interpret see my function declaration?!"), it would be nice to remove.
Comment 1 Igor Bukanov 2011-08-30 23:41:25 PDT
Comment on attachment 557052 [details] [diff] [review]
rm JS_LONE_INTERPRET

Yes, it is time to remove this.
Comment 3 Ed Morley [:emorley] 2011-09-01 01:42:33 PDT
http://hg.mozilla.org/mozilla-central/rev/8f345f65a9a0

Note You need to log in before you can comment on or make changes to this bug.