Closed Bug 68341 Opened 24 years ago Closed 21 years ago

Account Settings: Needs mnemonics


(SeaMonkey :: MailNews: Account Configuration, defect)

Not set


(Not tracked)



(Reporter: nbaca, Assigned: Stefan.Borggraefe)


(Blocks 1 open bug, )


(Keywords: access)


(2 files, 4 obsolete files)

Build 2001-02-09-04: NT4, Linux RH 6.2

Overview: The Account Settings dialogs have no mnemonics.

Expected Results: According to the Account Setup spec there should be mnemonics
in the Account Settings panels (i.e. Account Settings, Server Settings, Copies
and Folders Settings)
Marking nsbeta1 for accessibility reasons.
Keywords: access, nsbeta1
QA Contact: esther → nbaca
marking nsbeta1-. This sounds like a potential post beta bug.
Keywords: nsbeta1nsbeta1-
Target Milestone: --- → Future
Keywords: nsCatFood
Blocks: accesskey
jglick, can you update the spec for the Account Manager? Using `H' as the 
accesskey for the `Check new messages...' isn't available anymore since it's 
being using for the `Help' button. 

When trying to fix this bug I also ran into problems where labels, for instance 
the `Use secure connection (SSL)' label, used different accesskeys in different 
types of accounts. It uses `T' in POP and IMAP, but switches to `O' in NNTP. 
This is a problem because the label and the accesskey are only defined once in 
the .dtd, so only one accesskey can be used. Even worse is the `Local 
directory:' label which uses a different accesskey in each type of account. The 
problem could be fixed by making labels that are the same with different 
accesskeys, but being consistent and using the same accesskey across all 
accounts seems better to me.
Updated spec should show up shortly. If i missed anything, let me know.
Attached patch patch (obsolete) — Splinter Review
This patch is based on the Specs:

But some accesskeys are modified according to the accesskey guildlines.
Attachment #119280 - Flags: review?(timeless)
mass re-assign.
Assignee: racham → sspitzer
Comment on attachment 119280 [details] [diff] [review]

I just tried this patch. It doesn't apply anymore and needs to be updated. :-(
Attachment #119280 - Attachment is obsolete: true
Attachment #119280 - Flags: review?(timeless)
I just tried to fix this bug and then realized, that without bug 143065 fixed,
there are not enough characters in the alphabet to assign a unique key to every

So this bug is blocked by bug 143065.
Depends on: 143065
OS: Windows NT → All
I disagree. These panels are pages, not tabpanels, so the only thing you have to
be careful of are the add/default/remove buttons.
No longer depends on: 143065
Neil is right. I made a mistake when I tried this.

Taking bug.
Assignee: sspitzer → borggraefe
Attached patch Updated patch (obsolete) — Splinter Review
I also removed some unused strings where I spotted them.
Attachment #136035 - Flags: review?(timeless)
Attachment #136035 - Flags: review?(timeless)
Attached patch Updated once again (obsolete) — Splinter Review
Attachment #136035 - Attachment is obsolete: true
Attachment #136276 - Flags: review?(
Attachment #136276 - Flags: review?(
I just changed the accesskey for "&Leave in my Inbox" to "Leave in my &Inbox"
to make this consistent with the keys used in bug 40759.
Attachment #136276 - Attachment is obsolete: true
Attachment #136492 - Flags: review?(
Comment on attachment 136492 [details] [diff] [review]
Updated to reflect a change in bug 40759

>   <button id="encryptionCertClearButton"
>-          label="&certificate_clear.button;"
>+          label="&encryption.certificate_clear.button;"
>+          accesskey="&encryption.certificate_clear.button.accesskey;"
Ideally, just encryption.certificate_clear.accesskey (and similarly in other
places) will do.

Other nits (with no particular reference):
Automatically &quote
(you can ignore/remove menulist item access keys)
Set De&fault (to match account manager)
Server supports &folders
Personal &namespace
That's assuming that I've not introduced new conflicts, of course ;-)
Attachment #136492 - Flags: review?( → review+
>Ideally, just encryption.certificate_clear.accesskey (and similarly in
>other places) will do.
>Automatically &quote
>(you can ignore/remove menulist item access keys)
>Set De&fault (to match account manager)
>Server supports &folders


>Personal &namespace

This is not possible because the accesskey "n" matches Perso&nal. So I left
these two as they were in the last patch.

I also found and fixed another small bug in am-addressing.xul: The control
attributes of the labels left from the drop-down menus were wrong ("Then," and
"place my signature"). So the access keys for these menus were not working.
Attachment #136492 - Attachment is obsolete: true
Attachment #136527 - Flags: superreview?(bienvenu)
Attachment #136527 - Flags: review?(
This needs to be checked in for TB so the Account Manager does not break there.
Attachment #136528 - Flags: superreview?(bienvenu)
Attachment #136528 - Flags: review?(bienvenu)
Attachment #136527 - Flags: review?( → review+
Attachment #136527 - Flags: superreview?(bienvenu) → superreview+
Attachment #136528 - Flags: superreview?(bienvenu)
Attachment #136528 - Flags: superreview+
Attachment #136528 - Flags: review?(bienvenu)
Attachment #136528 - Flags: review+
Comment on attachment 136527 [details] [diff] [review]
Addressed review comments

Requesting approval for 1.6b. This adds access keys to all panels and child
dialogs of the Account Settings. Low risk.

David: Could you check this in for me if/when this gets approved?
Attachment #136527 - Flags: approval1.6b?
Comment on attachment 136527 [details] [diff] [review]
Addressed review comments

a=asa (on behalf of drivers) for checkin to 1.6beta
Attachment #136527 - Flags: approval1.6b? → approval1.6b+
I can check this in later this afternoon, along with the thunderbird patch.
fixes checked in.
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.