Closed Bug 683461 Opened 9 years ago Closed 9 years ago

Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash crash

Categories

(Firefox for Android Graveyard :: General, defect, critical)

Firefox 9
ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 9

People

(Reporter: Usul, Assigned: dougt)

Details

(Keywords: crash, topcrash, Whiteboard: QA?)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-8d291954-10f1-4d67-bcfa-1dff42110829 .
============================================================= 

0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:66
1 	libc.so 	libc.so@0x19c6a 	
2 	libdvm.so 	libdvm.so@0x8dc72 	
3 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	other-licenses/android/APKOpen.cpp:243
4 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	other-licenses/android/APKOpen.cpp:243
5 	libdvm.so 	libdvm.so@0x17e77 	
6 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f9703 	
7 	dalvik-heap (deleted) 	dalvik-heap @0x65c40f 	
8 	libdvm.so 	libdvm.so@0x49722 	
9 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x117d2 	
10 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	other-licenses/android/APKOpen.cpp:243
11 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f9703 	
12 	libdvm.so 	libdvm.so@0x496dc 	
13 	dalvik-heap (deleted) 	dalvik-heap @0x65c40f 	
14 	libdvm.so 	libdvm.so@0x4eea4 	
15 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f9703 	
16 	data@app@org.mozilla.fennec-2.apk@classes.dex 	data@app@org.mozilla.fennec-2.apk@classes.dex@0x86b1 	
17 	dalvik-heap (deleted) 	dalvik-heap @0x65c40f 	
18 	libdvm.so 	libdvm.so@0x1803f 	
19 	libdvm.so 	libdvm.so@0x1d077 	
20 	libdvm.so 	libdvm.so@0xa5373 	
21 	libdvm.so 	libdvm.so@0x22127 	
22 	libdvm.so 	libdvm.so@0x22097 	
23 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0xb1133 	
24 	libdvm.so 	libdvm.so@0x2101f 	
25 	libdvm.so 	libdvm.so@0x1ccf3 	
26 	libdvm.so 	libdvm.so@0x7f770 	
27 	dalvik-heap (deleted) 	dalvik-heap @0x416af 	
28 	core.odex 	core.odex@0xd3387 	
29 	dalvik-heap (deleted) 	dalvik-heap @0x78251f 	
30 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x1f373f 	
31 	dalvik-heap (deleted) 	dalvik-heap @0x39fff6f 	
32 	libdvm.so 	libdvm.so@0xa9b17 	
33 	dalvik-heap (deleted) 	dalvik-heap @0x506bff 	
34 	libdvm.so 	libdvm.so@0x1cd57 	
35 	libdvm.so 	libdvm.so@0x1cdcf 	
36 	libdvm.so 	libdvm.so@0x1cc77 	
37 	libdvm.so 	libdvm.so@0x1cc9f 	
38 	libdvm.so 	libdvm.so@0x1cccf 	
39 	libdvm.so 	libdvm.so@0x1ccf3 	
40 	libdvm.so 	libdvm.so@0x7f770 	
41 	core.odex 	core.odex@0xb27e1 	
42 	core.odex 	core.odex@0xb27e1 	
43 	core.odex 	core.odex@0xb27c9

Weird trace missing plenty of symbols.
Oom crash, I guess.
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> Oom crash, I guess.

I seem to be getting a lot of these :(
The stack looks funny because it's on the main thread, which is mostly Android Java code and system libraries.
This is kind of what I would expect to see when we catch a Java exception and then abort (which is what reportJavaCrash does), but the report doesn't show an exception and it's also missing a CrashTime field for some reason.
I do not think it is a oom here.  my guess is it's that nsJNIString before reporting.  I wonder if the implict JNI() call in the string is going to do bad stuff to the runtime.
Assignee: nobody → doug.turner
I believe that it may be a duplicate of bug 679176
nhirata - unrelated.
Summary: crash mozalloc_abort → Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash crash
shooting in the dark.  I don't have proof that using the implicit JNI() inside the nsJNIString is bad, but I have my suspicions.
Attachment #557667 - Flags: review?(josh)
Comment on attachment 557667 [details] [diff] [review]
use the correct jni

Looks sensible to me.
Attachment #557667 - Flags: review?(josh) → review+
Although fix the indent, please.
Comment on attachment 557667 [details] [diff] [review]
use the correct jni

(ws fixes not included)
Keywords: topcrash
http://hg.mozilla.org/mozilla-central/rev/d589ee7f704b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:9.0a2) Gecko/20111012 Firefox/9.0a2 Fennec/9.0a2
Device: HTC Desire Z
OS: Android 2.3

I have not seen this crash using above environment. Is there a particular scenario for this crash or can I jus mark it as VERIFIED FIXED?
Whiteboard: QA?
Crash Signature: [@ mozalloc_abort | libc.so@0x19c6a] → [@ mozalloc_abort | libc.so@0x19c6a] [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash]
You need to log in before you can comment on or make changes to this bug.