Last Comment Bug 683654 - Make TraceVis compile and run again.
: Make TraceVis compile and run again.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla9
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 11:30 PDT by Terrence Cole [:terrence]
Modified: 2011-09-01 13:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Minimal fix to make TraceVis run again. (3.54 KB, patch)
2011-08-31 11:30 PDT, Terrence Cole [:terrence]
dmandelin: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2011-08-31 11:30:21 PDT
Created attachment 557261 [details] [diff] [review]
Minimal fix to make TraceVis run again.

It appears to have bitrotted and needs some minor fixes to compile.
Comment 1 David Mandelin [:dmandelin] 2011-08-31 11:39:18 PDT
Comment on attachment 557261 [details] [diff] [review]
Minimal fix to make TraceVis run again.

Review of attachment 557261 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks OK. I wouldn't bother working too much on this, though, because IonMonkey is expected to replace the existing JITs.
Comment 2 Terrence Cole [:terrence] 2011-08-31 11:51:21 PDT
Agreed, and thank you for the review!  I wanted to give it a look to get ideas for implementing similar tracing on the GC.  Consensus in IRC was that I should submit the patch despite my reservations, since I already had it working.
Comment 3 Bill McCloskey (:billm) 2011-08-31 11:56:03 PDT
(In reply to Terrence Cole from comment #2)
> Agreed, and thank you for the review!  I wanted to give it a look to get
> ideas for implementing similar tracing on the GC.  Consensus in IRC was that
> I should submit the patch despite my reservations, since I already had it
> working.

Hi Terrence. Let me know what your plans are for this. I have some tools that I've been working on too.
Comment 4 Ed Morley [:emorley] 2011-08-31 15:06:43 PDT
In my queue :-)
Comment 5 Ed Morley [:emorley] 2011-09-01 00:31:26 PDT
As mentioned in bug 646597, the first try run was busted by bug 682677's patch, and now the second has failed, likely due to bug 646597:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=ddfa68e986d8

I've sent this to try again, and presuming green this time (third time lucky!), will push to inbound after:
http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=c902a63fb74c
Comment 7 Ed Morley [:emorley] 2011-09-01 13:54:07 PDT
http://hg.mozilla.org/mozilla-central/rev/bcc474c726aa

Note You need to log in before you can comment on or make changes to this bug.