Last Comment Bug 683729 - GCC 4.6 build warning: "js/src/vm/Debugger.cpp:874:11: warning: variable ‘frame’ set but not used [-Wunused-but-set-variable]"
: GCC 4.6 build warning: "js/src/vm/Debugger.cpp:874:11: warning: variable ‘fra...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2011-08-31 14:19 PDT by Daniel Holbert [:dholbert]
Modified: 2011-09-01 13:52 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix: remove unused variable (968 bytes, patch)
2011-08-31 14:33 PDT, Daniel Holbert [:dholbert]
jorendorff: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-08-31 14:19:38 PDT
Filing bug on this build warning:

> js/src/vm/Debugger.cpp: In static member function ‘static JSTrapStatus js::Debugger::onTrap(JSContext*, js::Value*)’:
> js/src/vm/Debugger.cpp:874:11: warning: variable ‘frame’ set but not used [-Wunused-but-set-variable]

The variable is declared like so...
> 874     Value frame = UndefinedValue();
https://mxr.mozilla.org/mozilla-central/source/js/src/vm/Debugger.cpp#874
...and is never used after that. (That's actually been the case since its first checkin: https://hg.mozilla.org/mozilla-central/rev/45f1cf2c59d2#l63.306 )
Comment 1 Daniel Holbert [:dholbert] 2011-08-31 14:33:34 PDT
Created attachment 557328 [details] [diff] [review]
fix: remove unused variable
Comment 2 Jason Orendorff [:jorendorff] 2011-08-31 14:41:03 PDT
Comment on attachment 557328 [details] [diff] [review]
fix: remove unused variable

Yep. Mental flotsam.
Comment 3 Daniel Holbert [:dholbert] 2011-09-01 00:14:25 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/dc12ae87f5b9
Comment 4 Ed Morley [:emorley] 2011-09-01 13:52:49 PDT
http://hg.mozilla.org/mozilla-central/rev/dc12ae87f5b9

Note You need to log in before you can comment on or make changes to this bug.