[ps] Mozilla uses only built-in AFM metrics

RESOLVED FIXED in mozilla1.0.1

Status

()

--
critical
RESOLVED FIXED
18 years ago
16 years ago

People

(Reporter: nidd, Assigned: dcone)

Tracking

({crash, helpwanted})

Trunk
mozilla1.0.1
x86
Linux
crash, helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
281              nsAFMObject::AFM_ReadFile(const nsFont &aFontName)
282              {
...
289 dcone    1.10 char* AFMFileName= aFontName.name.ToNewUTF8String(); // file
we will open

AFMFileName contains the name of the nsFont. This is usually "serif", but
sometimes "san-serif", or "fixed".

290
291                 if(nsnull == AFMFileName)
292                   return (success);
293
294                   if((0==strcmp(AFMFileName,"..")) ||
(0==strcmp(AFMFileName,"."))) {
295                     Recycle(AFMFileName);
296                     return (success);
297                   }
298
299                  // Open the file
300                 mAFMFile = fopen((const char *)AFMFileName,"r");

So, this function opens file "serif", "san-serif", or "fixed" file in current
directory and looks for AFM metrics there!!!! So this functions doesn't work.
The possible solution is to look for .afm file in user-specified directory.

Another promblem, is when I try to use Unicode PS font from
http://bibliofile.mc.duke.edu/gww/fonts/Unicode.html mozilla makes a core when
tries to read metrics.

Comment 1

18 years ago
Marking NEW. Seems to make sense to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Added crash keyword set target to mozilla0.9.1
Keywords: crash
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 3

18 years ago
I don't understand the problem.. this will read in what every afm file, you just 
have to put it into the directory..those are just the defaults.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

18 years ago
In what directory. I need to put afm files into current dictionary
and name them serif, san-serif, etc.?
I think there should be centralized font repositary?

Updated

18 years ago
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → mozilla0.9.3
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.6

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0

Comment 5

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Summary: Mozilla uses only built-in AFM metrics → [ps] Mozilla uses only built-in AFM metrics
(Reporter)

Comment 6

17 years ago
This bug is almost 1,5 years old. it is still critical and there is no work done
to fix it. I seems that it is not critical for you. Maybe we should lower the
severity and hope that it will be fixed?

Comment 7

17 years ago
Peter 'Nidd' Novodvorsky wrote:
> This bug is almost 1,5 years old. it is still critical and there is no work 
> done to fix it.

The Xprint module (which is a complete, full replacement for the PostScript
module) has this functionality (see
http://mozilla.org/releases/mozilla1.0/#printing).

Updated

17 years ago
Blocks: 157675

Comment 8

16 years ago
Now that the PS module has Truetype to Postscript printing (bug 144663) can we 
close this?

Comment 9

16 years ago
fixed by bug 144663 since we can use true type font to print.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.