Last Comment Bug 684135 - Shutdown crash reporting exception [@ nsTHashtable<nsBaseHashtableET<nsUint64HashKey, nsGlobalWindow*> >::GetEntry ]
: Shutdown crash reporting exception [@ nsTHashtable<nsBaseHashtableET<nsUint64...
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Linux
: -- critical (vote)
: mozilla9
Assigned To: Blake Kaplan (:mrbkap)
:
Mentors:
Depends on:
Blocks: 670896
  Show dependency treegraph
 
Reported: 2011-09-01 19:02 PDT by Blake Kaplan (:mrbkap)
Modified: 2011-09-11 15:52 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (5.19 KB, text/plain)
2011-09-01 19:02 PDT, Blake Kaplan (:mrbkap)
no flags Details
patch v1 (939 bytes, patch)
2011-09-01 19:22 PDT, Blake Kaplan (:mrbkap)
bzbarsky: review+
Details | Diff | Splinter Review

Description Blake Kaplan (:mrbkap) 2011-09-01 19:02:28 PDT
Created attachment 557740 [details]
stack

While shutting down, I crashed today trying to report an exception (see the attached stack). What appears to have happened is that during shutdown some sort of "race" in an extension I have caused an exception to be thrown from an nsITimer callback. Reporting the exception in XPConnect tries to get the inner window from the inner window ID. However, we're already far enough into shutdown that the call to nsGlobalWindow::GetInnerWindowWithId crashes because we've already nulled out nsGlobalWindow::sWindowsById.
Comment 1 Blake Kaplan (:mrbkap) 2011-09-01 19:22:25 PDT
Created attachment 557745 [details] [diff] [review]
patch v1

I can see a few ways of fixing this: add the null check here or in nsScriptError or check that we're in shutdown somehow in nsScriptError. I don't have a strong opinion for any of the options though.

I haven't been able to reproduce the crash since the first time, sadly.
Comment 2 Boris Zbarsky [:bz] 2011-09-01 19:29:55 PDT
Comment on attachment 557745 [details] [diff] [review]
patch v1

r=me
Comment 3 Ed Morley [:emorley] 2011-09-04 16:59:47 PDT
http://hg.mozilla.org/mozilla-central/rev/d06e88a99f39

Note You need to log in before you can comment on or make changes to this bug.