Last Comment Bug 684213 - Improve the extraction code in the custom Android linker
: Improve the extraction code in the custom Android linker
Status: RESOLVED FIXED
[mobilestartupshrink][ts]
: mobile, perf
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 05:57 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2011-09-07 07:59 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Directly uncompress libraries into the mmap()ed cache files (3.49 KB, patch)
2011-09-02 06:17 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Directly uncompress libraries into the mmap()ed cache files (3.55 KB, patch)
2011-09-02 06:27 PDT, Mike Hommey [:glandium]
mwu.code: review+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-09-02 05:57:49 PDT
Looks like the current extraction code writes out the compressed entries in 4KB chunks. We might be able to improve this by increasing the buffer or some other mmap tweaks.
Comment 1 Mike Hommey [:glandium] 2011-09-02 06:17:21 PDT
Created attachment 557808 [details] [diff] [review]
Directly uncompress libraries into the mmap()ed cache files
Comment 2 Mike Hommey [:glandium] 2011-09-02 06:27:13 PDT
Created attachment 557810 [details] [diff] [review]
Directly uncompress libraries into the mmap()ed cache files

Previous one forgot to change the mmap size

Note You need to log in before you can comment on or make changes to this bug.