crash DocumentViewerImpl::SetBounds

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

16 Branch
crash
Points:
---

Firefox Tracking Flags

(firefox8?, firefox16+ wontfix, firefox17-)

Details

(Whiteboard: [startupcrash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-865918d9-449c-47d6-8888-91f2d2110902 .
============================================================= 

Seen while looking at crash data. Mac specific crash that ranks #11, https://crash-stats.mozilla.com/report/list?signature=DocumentViewerImpl::SetBounds to the report which span several versions. No useful comments or correlations. Seems to have been a small spike in the Beta. Filing so we can keep on eye on this one.

Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	DocumentViewerImpl::SetBounds 	layout/base/nsDocumentViewer.cpp:1949
1 	XUL 	DocumentViewerImpl::SetBounds 	layout/base/nsDocumentViewer.cpp:1949
2 	XUL 	nsDocShell::SetPositionAndSize 	docshell/base/nsDocShell.cpp:4695
3 	XUL 	nsWebShellWindow::HandleEvent 	xpfe/appshell/src/nsWebShellWindow.cpp:353
4 	XUL 	nsCocoaWindow::DispatchEvent 	widget/src/cocoa/nsCocoaWindow.mm:1332
5 	XUL 	nsCocoaWindow::ReportSizeEvent 	widget/src/cocoa/nsCocoaWindow.mm:1394
6 	Foundation 	_nsnote_callback 	
7 	CoreFoundation 	__CFXNotificationPost 	
8 	CoreFoundation 	_CFXNotificationPostNotification 	
9 	Foundation 	-[NSNotificationCenter postNotificationName:object:userInfo:] 	
10 	AppKit 	-[NSWindow _setFrameCommon:display:stashSize:] 	
11 	AppKit 	-[NSWindow zoom:] 	
12 	XUL 	nsCocoaWindow::SetSizeMode 	widget/src/cocoa/nsCocoaWindow.mm:1041
13 	XUL 	nsXULWindow::LoadMiscPersistentAttributesFromXUL 	xpfe/appshell/src/nsXULWindow.cpp:1255
14 	XUL 	nsXULWindow::OnChromeLoaded 	xpfe/appshell/src/nsXULWindow.cpp:1030
15 	XUL 	nsWebShellWindow::OnStateChange 	xpfe/appshell/src/nsWebShellWindow.cpp:591
16 	XUL 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1339
17 	XUL 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.cpp:958
18 	XUL 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.h:204
19 	XUL 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:707
20 	XUL 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:734
21 	XUL 	nsDocument::DoUnblockOnload 	content/base/src/nsDocument.cpp:7216
22 	XUL 	nsDocument::DispatchContentLoadedEvents 	content/base/src/nsDocument.cpp:4204
23 	XUL 	nsRunnableMethodImpl<void ,true>::Run 	nsThreadUtils.h:341
24 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:617
25 	XUL 	NS_ProcessPendingEvents_P 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:195
26 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
27 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:422
28 	CoreFoundation 	__CFRunLoopDoSources0 	
29 	CoreFoundation 	__CFRunLoopRun 	
30 	CoreFoundation 	CFRunLoopRunSpecific 	
31 	HIToolbox 	HIToolbox@0x2e7ed 	
32 	HIToolbox 	HIToolbox@0x2e5f2 	
33 	HIToolbox 	HIToolbox@0x2e4ab 	
34 	AppKit 	_DPSNextEvent 	
35 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
36 	AppKit 	-[NSApplication run] 	
37 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:769
38 	XUL 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:222
39 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3570
40 	firefox 	main 	browser/app/nsBrowserApp.cpp:198
41 	firefox 	firefox@0xb73
This happens on Linux as well, but in smaller volume.

Comment 2

7 years ago
It's #3 top crasher in 7.0.1 and #11 in 8.0b1 on Mac OS X.

7.0.1 correlations per add-on are:
* Mac:
  DocumentViewerImpl::SetBounds|EXC_BAD_ACCESS / 0x0000000d (33 crashes)
     24% (8/33) vs.   2% (20/1251) {635abd67-4fe9-1b23-4f01-e679fa7484c1} (Yahoo! Toolbar, https://addons.mozilla.org/addon/2032)
     12% (4/33) vs.   5% (62/1251) foxmarks@kei.com (Xmarks (formerly Foxmarks), https://addons.mozilla.org/addon/2410)
* Windows:
  DocumentViewerImpl::SetBounds(nsIntRect const&)|EXCEPTION_ACCESS_VIOLATION_READ (38 crashes)
    100% (38/38) vs.   1% (592/57390) {64161300-e22b-11db-8314-0800200c9a66} (Speed Dial, https://addons.mozilla.org/addon/4810)
     53% (20/38) vs.   2% (1338/57390) {EEE6C361-6118-11DC-9C72-001320C79847} (SweetIM toolbar)
Crash Signature: [@ DocumentViewerImpl::SetBounds] → [@ DocumentViewerImpl::SetBounds] [@ DocumentViewerImpl::SetBounds(nsIntRect const&) ]
tracking-firefox8: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Version: 8 Branch → 7 Branch

Comment 3

7 years ago
---------------------------------[ Triage Comment ]---------------------------------

Marcia, is this something we care about for Firefox 8? The latest channel meeting said beta stability was fine and searching for those signatures gives than 1000 crashes in the last week across all Firefox versions (and the signatures go all the way back to 3.6).
Keywords: #relman/triage/needs-info
Probably would be worth it if we could reproduce it, but there right now is not much to go on except a 26% correlation to Yahoo Toolbar and some mention in the comments about print previewing a Yahoo News article. We should probably consider tracking just to see how it does for the rest of the Beta 8 cycle.

(In reply to Christian Legnitto [:LegNeato] from comment #3)
> ---------------------------------[ Triage Comment
> ]---------------------------------
> 
> Marcia, is this something we care about for Firefox 8? The latest channel
> meeting said beta stability was fine and searching for those signatures
> gives than 1000 crashes in the last week across all Firefox versions (and
> the signatures go all the way back to 3.6).
tracking-firefox8: ? → -

Comment 5

7 years ago
It's now #1 top browser crasher on Mac OS X in 7.0.1 and #2 in 8.0b5.
There have been no crashes in 9.0a2 or 10.0a1.
I don't know if it's fixed in 9.0 or if the Aurora/Nightly panel is too small to reproduce it.
tracking-firefox8: - → ?
Keywords: topcrash
I am going to get some URLs to see if we can try to reproduce the issue.
Keywords: needURLs
Here are some URLs that I culled for the first signature from October:

1 http://abuchak.net/
      1 http://apple.com/
      1 http://apps.facebook.com/empiresandallies/?ref=bookmarks&count=0&fb_source=bookmarks_apps&fb_bmpos=1_0
      1 http://att.my.yahoo.com/?isUpgrade=1
      1 http://auspost.com.au/track/
      1 http://azcentral.com/
      1 http://broward.granicus.com/MediaPlayer.php?publish_id=16
      1 http://ca.msn.com/defaultf.aspx
      1 http://ca.yahoo.com/
      1 http://chandleraz.granicus.com/MediaPlayer.php?view_id=10&event_id=3
      1 http://chronicle.com/forums/index.php/board,30.0.html
      1 http://commerce.queensu.ca/commerce/2006/commerce.nsf/homepage?OpenForm&section=National
      1 http://cts.vresp.com/c/?CompeGPSTeamSL/f0a152ce24/797fa39b9f/4488483540/utm_source=newsletter&utm_medium=email&utm_campaign=reduction_twonav
      1 http://devel.corp.yahoo.com/
      1 http://de.yahoo.com/
      1 http://drudgereport.com/
      1 http://e.bloomingdales.com/
      1 http://edition.cnn.com/
      1 http://en-us.start2.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official
      1 http://en.wikipedia.org/wiki/Craig_Roberts
      1 http://en.wikipedia.org/wiki/Main_Page
      1 http://eplaya.burningman.com/
      1 http://espanol.yahoo.com/_ylt=Ap93PsHIsOevJxtqAKdSaYBUcbt_/SIG=11g6kbbdc/EXP=1319755490/**http%3A//espanol.yahoo.com/set
      1 http://espncleveland.com/
      1 http://es.search.yahoo.com/firefox/?fr=yff50-sfp
      1 http://es.shop.wacom.eu/Productos/Bamboo/Bamboo-Pen-und-Touch
      1 http://eu1.badoo.com/signout/
      1 http://facebook.com/
      1 http://finance.yahoo.com/
      1 http://football.fantasysports.yahoo.com/f1/423776/7?week=7
      1 http://forum.tuts4you.com/files/file/406-traynote-12/
      1 http://fr.copytrans.net/socialmedia_redirect.php?program=CopyTrans%20Manager&version=0.952&language=French&action=added&service=facebook&count=18
      1 http://free4him.com/for-the-family/bed-bath-beyond-chevy-giveaway/
      1 http://fr.start2.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:fr:official
      1 http://fr.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:fr:official
      1 http://games.aarp.org/
      1 http://go2.microsoft.com/fwlink/?LinkId=116053
      1 http://goodcomputers.co.nr/
      1 http://gsd.adservices.be/test/dashboard.aspx
      1 http://halloweenorwilliamsburg.tumblr.com/
      1 http://hk.yahoo.com/
      1 http://home.allgameshome.com/
      1 http://home.suddenlink.net/news/?sc_cid=directory_news
      1 http://home.verizon.yahoo.com/
      1 http://hp7d0c14.local./
      1 http://idp.mred.safemls.net/idp/Authn/UserPassword
      1 http://itsallaboutthehealth.tumblr.com/post/11723615258
      1 http://jackson-rathbone.com/
      1 http://jjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj
      1 http://jp.msn.com/
      1 http://kleinanzeigen.ebay.de/anzeigen/
      1 http://mail.yahoo.com/
      1 http://mail.yahoo.com/?.refer=slv&.intl=us
      1 http://mamelles.net/
      1 http://m.fr.yahoo.com/
      1 http://movies.netflix.com/WiHome
Some of the correlation data based on 51 crashes shows some correlation to Yahoo Toolbar:

45% (23/51) vs.   2% (42/2028) {635abd67-4fe9-1b23-4f01-e679fa7484c1} (Yahoo! Toolbar, https://addons.mozilla.org/addon/2032)
     18% (9/51) vs.   1% (21/2028) {4176DFF4-4698-11DE-BEEB-45DA55D89593} (AniWeather, https://addons.mozilla.org/addon/12331)
     10% (5/51) vs.   3% (51/2028) {195A3098-0BD5-4e90-AE22-BA1C540AFD1E} (Garmin Communicator, https://addons.mozilla.org/addon/10278)
     98% (50/51) vs.  92% (1857/2028) {972ce4c6-7e08-4474-a285-3208198ce6fd} (Default, https://addons.mozilla.org/addon/8150)
      8% (4/51) vs.   2% (39/2028) {9AA46F4F-4DC7-4c06-97AF-5035170634FE} (ImTranslator, https://addons.mozilla.org/addon/2257)
      8% (4/51) vs.   2% (39/2028) {7b13ec3e-999a-4b70-b9cb-2617b8323822}
     10% (5/51) vs.   4% (80/2028) personas@christopher.beard (Personas, https://addons.mozilla.org/addon/10900)
(Reporter)

Updated

7 years ago
Keywords: needURLs

Comment 9

7 years ago
One comment says: "problem started with trying to download a movie on netflix. Required a re-start in the 32 bit mode."

Comment 10

7 years ago
This is sitting at #264 on 8.0 and #116 on 8.0.1. I don't see it in the top 300 list for 9.0b4 or 9.0b5. I am going to remove the top crash keyword.
Keywords: topcrash

Comment 11

7 years ago
(In reply to Sheila Mooney from comment #10)
> This is sitting at #264 on 8.0 and #116 on 8.0.1.
But it's #3 top crasher in 8.0.1 on Mac OS X.

Comment 12

6 years ago
It's #1 top crasher in 16.0b3 on Mac OS X with many dupes (startup crash).

The stack trace now looks like:
Frame 	Module 	Signature 	Source
0 	XUL 	DocumentViewerImpl::SetBounds 	nsDocumentViewer.cpp:1905
1 	XUL 	DocumentViewerImpl::SetBounds 	nsDocumentViewer.cpp:1905
2 	XUL 	nsWebShellWindow::WindowResized 	nsWebShellWindow.cpp:256
3 	AppKit 	AppKit@0x8da515 	
4 	XUL 	nsCocoaWindow::ReportSizeEvent 	nsCocoaWindow.mm:1550
5 	AppKit 	AppKit@0x8da515 	
6 	Foundation 	Foundation@0x16d0d 	
7 	CoreFoundation 	CoreFoundation@0x4c7b9 	
8 	libmozglue.dylib 	je_calloc 	jemalloc.c:4227
9 	CoreFoundation 	CoreFoundation@0x7e00f 	
10 	Foundation 	Foundation@0x30c4 	
11 	Foundation 	Foundation@0x2fc2 	
12 	AppKit 	AppKit@0x10503b
Component: General → Layout
Keywords: topcrash
Product: Firefox → Core
Whiteboard: [startupcrash]
Version: 7 Branch → 16 Branch

Updated

6 years ago
tracking-firefox16: --- → +
Keywords: needURLs, qawanted
Let's try to reproduce with URLs and then look at what we changed in beta 3 since this appears to be a new regression.
Here are the URLs from the Beta 3 crashes:

Total Count 	URL
13 	http://heyduk.net/
8 	jar:file:///Users/cdanr/Library/Application%20Support/Firefox/Profiles/tbm956mk.
6 	http://www.yahoo.com/
6 	jar:file:///Applications/Firefox.app/Contents/MacOS/omni.ja!/chrome/browser/cont
6 	about:blank
2 	http://www.google.com/ig?hl=en&source=iglk
2 	http://www.google.com/ig
2 	jar:file:///Applications/Firefox/Firefox%20Beta.app/Contents/MacOS/omni.ja!/chro
1 	http://www.google.it/
1 	http://realityla.com/category/rla-music/#
1 	http://chriserickson.net/
1 	http://www.google.com/
1 	http://www.weather.com/weather/today/USIN0211
1 	http://www.minecraft.net/
1 	http://www.nytimes.com/
1 	http://www.moveon.org/
1 	http://www.wasatch.edu/wasatchsd/site/default.asp
1 	http://www.myplaniq.com/LTISystem/
1 	https://encrypted.google.com/
1 	http://google.dk/
1 	http://www.repubblica.it/
1 	http://www.google.co.th/
Keywords: needURLs

Updated

6 years ago
QA Contact: jbecerra

Comment 15

6 years ago
The Beta regression range is:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=cad589192f3c&tochange=de3f06a549de

It's highly correlated to Tab Mix Plus in 16.0b3.
Here are correlations per extension in 16.0 Beta during the last days:
* Sept 16:
     88% (15/17) vs.   5% (22/482) {dc572301-7619-498c-a57d-39143191b318} (Tab Mix Plus, https://addons.mozilla.org/addon/1122)
     88% (15/17) vs.   5% (25/482) isreaditlater@ideashower.com (Read It Later, https://addons.mozilla.org/addon/7661)
     88% (15/17) vs.   8% (39/482) {e4a8a97b-f2ed-450b-b12d-ee082ba24781} (Greasemonkey, https://addons.mozilla.org/addon/748)
     94% (16/17) vs.  18% (87/482) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
     59% (10/17) vs.   3% (14/482) firefox@ghostery.com (Ghostery, https://addons.mozilla.org/addon/9609)
     59% (10/17) vs.   5% (23/482) {DDC359D1-844A-42a7-9AA1-88A850A938A8} (DownThemAll!, https://addons.mozilla.org/addon/201)
     35% (6/17) vs.   5% (26/482) foxmarks@kei.com (Xmarks (formerly Foxmarks), https://addons.mozilla.org/addon/2410)
* Sept 17:
    100% (14/14) vs.  25% (79/319) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
     79% (11/14) vs.   8% (24/319) foxmarks@kei.com (Xmarks (formerly Foxmarks), https://addons.mozilla.org/addon/2410)
     79% (11/14) vs.   8% (27/319) firebug@software.joehewitt.com (Firebug, https://addons.mozilla.org/addon/1843)
     14% (2/14) vs.   3% (10/319) {dc572301-7619-498c-a57d-39143191b318} (Tab Mix Plus, https://addons.mozilla.org/addon/1122)
* Sept 18:
     91% (20/22) vs.   5% (26/548) {dc572301-7619-498c-a57d-39143191b318} (Tab Mix Plus, https://addons.mozilla.org/addon/1122)
     77% (17/22) vs.   4% (20/548) {6005d9b1-d115-485a-a92a-3f6453ca3fe2}
     73% (16/22) vs.   3% (16/548) {655397ca-4766-496b-b7a8-3a5b176ee4c2} (Searchbar Autosizer, https://addons.mozilla.org/addon/1172)
     73% (16/22) vs.   3% (16/548) {42975993-6fa0-46f5-a45f-706915f18ebf}
     73% (16/22) vs.   3% (17/548) {CE6E6E3B-84DD-4cac-9F63-8D2AE4F30A4B} (CoolPreviews, https://addons.mozilla.org/addon/2207)
     73% (16/22) vs.   5% (29/548) {1018e4d6-728f-4b20-ad56-37578a4de76b} (Flagfox, https://addons.mozilla.org/addon/5791)
     73% (16/22) vs.   8% (42/548) personas@christopher.beard (Personas, https://addons.mozilla.org/addon/10900)
     86% (19/22) vs.  22% (119/548) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
     45% (10/22) vs.   3% (15/548) translator@zoli.bod
     41% (9/22) vs.   2% (9/548) firefoxaddon@youtubeenhancer.com
     45% (10/22) vs.   9% (50/548) {23fcfd51-4958-4f00-80a3-ae97e717ed8b}
     36% (8/22) vs.   5% (27/548) {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} (Easy YouTube Video Downloader, https://addons.mozilla.org/addon/10137)
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0

Unable to reproduce the crash so far on Windows 7 and Mac OS X 10.6 with Firefox 16 beta 3 - I navigated to all the web sites from Comment 14 after installing the add-ons  mentioned in Comment 15.

Comment 17

6 years ago
There's only one crash in 16.0b4, probably because those who hit this crash on startup in 16.0b3 can't upgrade.
Keywords: topcrash
(In reply to Scoobidiver from comment #17)
> There's only one crash in 16.0b4, probably because those who hit this crash
> on startup in 16.0b3 can't upgrade.

This crash may very well be gone at this point. Rarely have we seen an explosive crasher that disappears completely in the next release.

Also, none of the comments appear to be about a startup crash, which leads me to believe it's not 100% of the time.
status-firefox16: --- → wontfix
tracking-firefox17: --- → +
Keywords: qawanted
Let's see if this appears again when 17 is on beta and there are more users, we'll stop tracking if it doesn't.
Not seeing this in 17.0b1, untracking.
tracking-firefox17: + → -
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) in Firefox (except some obsolete Fx <16).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.