Last Comment Bug 684312 - Webgl Water demo not working, with "compile error: ERROR: 0:1: 'unexpected EOF' : syntax error"
: Webgl Water demo not working, with "compile error: ERROR: 0:1: 'unexpected EO...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://madebyevan.com/webgl-water/
Depends on:
Blocks: 680722
  Show dependency treegraph
 
Reported: 2011-09-02 12:05 PDT by Daniel Holbert [:dholbert]
Modified: 2011-09-02 12:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Holbert [:dholbert] 2011-09-02 12:05:45 PDT
STR: Load http://madebyevan.com/webgl-water/
EXPECTED RESULTS: Pretty rippling water.
ACTUAL RESULTS:   Black canvas, saying:
  compile error: ERROR: 0:1: 'unexpected EOF' : syntax error

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e58e98a89827&tochange=e87454393401

Bug 680722 is the only checkin in that range to mention WebGL -- assuming regression from that.

(This might be a duplicate of bug 683710, which is also a regression from that checkin, but I'm filing this separately for now since the "compile error" warning message is different from the one mentioned on that bug.)
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-09-02 12:13:00 PDT
Indeed probably a duplicate of 683710. The most probable thing is that as the patch from bug 680722 causes ShaderSource to reject the source string, we're subsequently compiling an empty shader source, which would explain the unexpected-EOF message.

*** This bug has been marked as a duplicate of bug 683710 ***
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2011-09-02 12:45:18 PDT
Fixed by backout: http://hg.mozilla.org/mozilla-central/rev/e1d9d6120f84

Note You need to log in before you can comment on or make changes to this bug.