Last Comment Bug 684315 - Remove private browsing code from nsEditorSpellCheck.cpp
: Remove private browsing code from nsEditorSpellCheck.cpp
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: arno renevier
:
: Makoto Kato [:m_kato]
Mentors:
Depends on: 678842 679784
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 12:17 PDT by arno renevier
Modified: 2011-09-07 07:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch proposal (8.36 KB, patch)
2011-09-03 01:43 PDT, arno renevier
ehsan: review+
Details | Diff | Splinter Review
updated patch: use delete to deallocate gDictionaryStore (8.26 KB, patch)
2011-09-05 23:57 PDT, arno renevier
no flags Details | Diff | Splinter Review

Description arno renevier 2011-09-02 12:17:50 PDT
Since bug 679784 is fixed, it's possible to remove private browsing mode handling from nsEditorSpellCheck.cpp

I had deliberately not done that in bug 679784 to leave bug 679784 and bug 678842 independent. So, in case, one of them has to be backouted for whatever reason, this can be done without touching the other one.
Comment 1 :Ehsan Akhgari 2011-09-02 14:14:19 PDT
Are you interested in taking this, Arno?
Comment 2 arno renevier 2011-09-03 01:43:57 PDT
Created attachment 558049 [details] [diff] [review]
patch proposal

patch proposal.
Here is try server result:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&tree=Try&rev=226e2af677ba
Comment 3 :Ehsan Akhgari 2011-09-05 12:05:15 PDT
Comment on attachment 558049 [details] [diff] [review]
patch proposal

Review of attachment 558049 [details] [diff] [review]:
-----------------------------------------------------------------

r=me withe the comment below addressed.

::: editor/composer/src/nsEditorSpellCheck.cpp
@@ +747,5 @@
>  
>  void 
>  nsEditorSpellCheck::ShutDown() {
> +  if (gDictionaryStore) {
> +    nsMemory::Free(gDictionaryStore);

gDictionaryStore is allocated using operator new, so you should deallocate it using operator delete.
Comment 4 arno renevier 2011-09-05 23:57:35 PDT
Created attachment 558411 [details] [diff] [review]
updated patch: use delete to deallocate gDictionaryStore

Note You need to log in before you can comment on or make changes to this bug.