Frames reloads continiusly by itself

VERIFIED FIXED in mozilla1.0

Status

()

VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: ezh, Assigned: jst)

Tracking

({dom0, testcase})

Trunk
mozilla1.0
x86
Windows 2000
dom0, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [XPCDOM], URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Look at the URL you will notice it itself.

moz 2001020804

Comment 1

18 years ago
Created attachment 24973 [details]
Cause of reloading

Comment 2

18 years ago
Trying again... sorry for the inconvenience...

It's this little piece of JS in the 'main' page that makes it reload... I don't 
know *anything* about scripts, so I'm not gonna judge the validity of this... 
(it has script quotes around it in the real page)

       if (self.frames.name != 'info' && window.location.search =='')
         self.parent.location='index.php3?var_frame='+window.location.href;

Comment 3

18 years ago
Opera 4.01 have the same problem. I think it's a bug in the script and not in
Mozilla. Changing:
    self.frames.name != 'info'
to:
    name != 'info'
makes it work in Opera and Mozilla too.

Comment 4

18 years ago
The frameset is also odd because there's something like this:

<body>
<p>Этот сайт использует фреймы, а ваш браузер, к сожалению, их не поддерживает</p>
</body>

and this shouldn't be in there at all. Or they have to put that in between of
the <noframes> tags.

Comment 5

18 years ago
Created attachment 25191 [details]
frame content for testcase

Comment 6

18 years ago
Created attachment 25193 [details]
Testcase

Comment 7

18 years ago
Again, I don't think self.frames.name is supposed to work, but it does in NS4
and IE5, so let's ask the DOM experts.
Assignee: asa → jst
Component: Browser-General → DOM Level 0
Keywords: testcase
QA Contact: doronr → desale
Keywords: dom0

Updated

18 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 8

18 years ago
window.frames.name works in 4.x because window.frames == window in 4.x, in
mozilla that's not the case (window.frames is just a collection of windows, not
a window object). I'm debating wether or not I should fix this and I think I
might put this change into the XPConnectifying work that's going on right now.
The reason I'm not jumping on to fixing this is that the reason the testcase
uses self.frames.name is most likely just a typo, it doesn't make sense to do
that, self.name is what they wanted.
(Assignee)

Updated

18 years ago
Whiteboard: [XPCDOM]
(Assignee)

Comment 9

18 years ago
*** Bug 75097 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
Fixed by the xpcdom landing

Comment 11

17 years ago
Verified with 2001-08-28-08.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.