Clicking on a background tab's close button selects the tab before closing it

RESOLVED FIXED in Firefox 9

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Eric, Assigned: dao)

Tracking

({regression})

9 Branch
Firefox 9
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.03 KB, patch
Neil Deakin (mostly unavailable until September)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:9.0a1) Gecko/20110902 Firefox/9.0a1
Build ID: 20110902072738

Steps to reproduce:

Whenever I close a tab in Nightly, before the tab actually closes it will show the tab I am trying to close for a quick second before it will actually close it. This is only if you're on a different tab to the one you're trying to close.


Actual results:

I have explained in the above paragraph.


Expected results:

It shouldn't have shown the tab I was closing at all.

Comment 1

6 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

Please post the graphics section from about:support

Comment 2

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110902 Firefox/9.0a1

I'm getting this too, it's probably because of the fix for bug 679255.
(Reporter)

Comment 3

6 years ago
(In reply to Tim (fmdeveloper) from comment #1)
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode
> 
> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-
> profile
> 
> Please post the graphics section from about:support

I have just got done trying it in both safe mode & a new profile and the bug still persists. And according to the comment above this one I'm not the only person with this problem. Thanks for the reply.
(Reporter)

Comment 4

6 years ago
> Please post the graphics section from about:support


http://i.imgur.com/vJP4t.png

Comment 5

6 years ago
I think I see what you mean - it does briefly appear to change to the tab before closing

Confirming and cc'ing for additional eyes
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browser
Ever confirmed: true
QA Contact: general → tabbed.browser
(Assignee)

Updated

6 years ago
Assignee: nobody → dao
Blocks: 679255
Keywords: regression
(Assignee)

Updated

6 years ago
Summary: When I close a tab it shows the tab before closing it → Clicking on a background tab's close button selects the tab before closing it
(Assignee)

Comment 6

6 years ago
Created attachment 558284 [details] [diff] [review]
patch

I tried to write a test for this, but it's a pain since tabbrowser.xml uses setTimeout in addTab() to show the close button and tabbox.xml uses setTimeout in the mousedown handler.
Attachment #558284 - Flags: review?(enndeakin)

Updated

6 years ago
Duplicate of this bug: 684765

Comment 8

6 years ago
Note that there's another drawback from 679255's landing. Right-click on the active tab focuses the tab itself occasionally, showing the dotted lines.
Attachment #558284 - Flags: review?(enndeakin) → review+
http://hg.mozilla.org/mozilla-central/rev/016189c2245a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
(Assignee)

Updated

6 years ago
Duplicate of this bug: 685300
You need to log in before you can comment on or make changes to this bug.