Closed Bug 685069 Opened 10 years ago Closed 10 years ago

Killing nsIFrame::GetAdditionalChildListName introduced invalidation regression affecting full-screen

Categories

(Core :: Layout, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 684574

People

(Reporter: cpearce, Unassigned)

References

()

Details

Attachments

(1 file)

The landing of bug 653649 caused some kind invalidation regression which is affecting my work on the full-screen API (bug 545812).

Before the landing of bug 653649, when an element requests full-screen, the window will go full-screen and the browser's frame will hide, and the toolbar will "slide up" out of sight.

After the landing of bug 653649, the "slide up" doesn't invalidate properly (I assume), and you're left with artefacts/noise on the content that has "slid up".

For an example, point an up-to-date nightly at http://pearce.org.nz/full-screen/ , set the full-screen-api.enabled pref to true, and hit the <button> labelled "Fullscreen". Observe toolbar sliding away, leaving behind rendering artefacts.

[Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110906 Firefox/9.0a1, GPU Accelerated Windows: 2/2 Direct3D 10]
I should also mention, the bug definitely manifests in revision d9797d99f5f7 (which is part 4/5 of the patches for Bug 653649), but not in revision 3fbd9eaf9deb (the changeset preceding Bug 653649's patches). Part 2/5 and 3/5 wouldn't build by themselves for me, and I didn't try building Part 1/5 as it looks like it doesn't change any existing code.
Does the patch in bug 684574 fix it?
Yes! Awesome!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684574
You need to log in before you can comment on or make changes to this bug.