Last Comment Bug 685130 - Should build libffi as thumb when compiling for ARM
: Should build libffi as thumb when compiling for ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: js-ctypes (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 05:43 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-09-16 01:14 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Build libffi with the same flags as the rest (1.07 KB, patch)
2011-09-07 07:16 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2011-09-07 05:43:49 PDT
Currently libffi is built as ARM instead of thumb. The source supports thumb, we just need to pass the right compile flags.
Comment 1 Mike Hommey [:glandium] 2011-09-07 05:46:55 PDT
As mentioned on IRC, I think removing these 3 lines should work:
http://mxr.mozilla.org/mozilla-central/source/js/src/configure.in#5633
Comment 2 Mike Hommey [:glandium] 2011-09-07 07:16:54 PDT
Created attachment 558795 [details] [diff] [review]
Build libffi with the same flags as the rest

It looks like this has the desired effect.
Comment 3 Mike Hommey [:glandium] 2011-09-16 01:04:55 PDT
https://hg.mozilla.org/mozilla-central/rev/ad202468df63

Note You need to log in before you can comment on or make changes to this bug.