Building Fennec for Android on OSX results in broken binary

RESOLVED DUPLICATE of bug 694499

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 694499
7 years ago
6 years ago

People

(Reporter: snorp, Unassigned)

Tracking

({helpwanted, mobile})

Trunk
ARM
Android
helpwanted, mobile
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

When building Android Fennec on OSX, the resulting app crashes on startup. I get the following assertion:

I/stderr  (26175): Assertion failure: getSlot(slot).isUndefined(), at /Users/snorp/source/mozilla-central/js/src/jsobj.cpp:4862

It looks like maybe something is getting miscompiled?  Not sure what is going on.

Comment 1

7 years ago
I know Ehsan was trying to build Fennec on OSX; he might know something.

Comment 2

7 years ago
I didn't make any progress really.  I didn't know how to debug this...

I would also like to try building with clang, but I don't know how to do that either.
Keywords: helpwanted, mobile

Updated

6 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Fennec → Core
QA Contact: general → general

Comment 3

6 years ago
Doug, did you figure out something about this bug?  If yes, would you mind sharing the details please?  Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694499
You need to log in before you can comment on or make changes to this bug.