Pulse audio backend does not check provided playback and crashes

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: romaxa, Assigned: romaxa)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

On attempt to enabled pulseaudio backend I see this crash:
#0  strcpy () at ../ports/sysdeps/arm/strcpy.S:69
#1  0x3b50af44 in sa_stream_create_pcm (_s=0x4251bec8, client_name=0x0, mode=SA_MODE_WRONLY, format=SA_PCM_FORMAT_S16_LE, rate=44100, n_channels=994955412)
    at /home/romaxa/mozdev/mozillahg/mozilla-central/media/libsydneyaudio/src/sydney_audio_pulseaudio.c:219
#2  0x00000000 in ?? ()
Not sure if it will be useful after bug 623444 fix... but anyway.
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #558905 - Flags: review?(tterribe)
Attachment #558905 - Flags: review?(tterribe) → review+
Keywords: checkin-needed
Keywords: checkin-needed
Whiteboard: [inbound]
This was backed out of mozilla-inbound as part of this push <https://tbpl.mozilla.org/?tree=Mozilla-Inbound&usebuildbot=1&rev=9f150c4e1a48> which turned the 32-bit OS X reftests perma-orange.
Whiteboard: [inbound]
Depends on: 852401
sydneyaudio has been removed from the tree.  The PulseAudio backend for cubeb does not suffer from this bug, so marking fixed.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.