Last Comment Bug 685518 - Shouldn't taint the canvas when drawing images with @crossorigin into it
: Shouldn't taint the canvas when drawing images with @crossorigin into it
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: unspecified
: x86 Mac OS X
: P1 normal (vote)
: mozilla9
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
:
Mentors:
Depends on: 664299
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-08 06:18 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2011-11-17 10:46 PST (History)
7 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1. Look at the image CORS mode for drawImage into a canvas 2d context. (16.10 KB, patch)
2011-09-08 10:29 PDT, Boris Zbarsky [:bz] (still a bit busy)
roc: review+
Details | Diff | Splinter Review
part 2. Move the crossorigin webgl test to a saner location so I can add cross-origin non-webgl tests. (11.02 KB, patch)
2011-09-08 10:30 PDT, Boris Zbarsky [:bz] (still a bit busy)
roc: review+
Details | Diff | Splinter Review
part 3. Add crossorigin 2d canvas tests. (6.53 KB, patch)
2011-09-08 10:30 PDT, Boris Zbarsky [:bz] (still a bit busy)
roc: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2011-09-08 06:18:47 PDT
For some reason this wasn't done in bug 664299 and followups, and since Chrome did implement this, people are hitting it as a problem now....
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-09-08 10:29:17 PDT
Created attachment 559211 [details] [diff] [review]
part 1.  Look at the image CORS mode for drawImage into a canvas 2d context.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-09-08 10:30:02 PDT
Created attachment 559212 [details] [diff] [review]
part 2.  Move the crossorigin webgl test to a saner location so I can add cross-origin non-webgl tests.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-09-08 10:30:51 PDT
Created attachment 559213 [details] [diff] [review]
part 3.  Add crossorigin 2d canvas tests.

Note You need to log in before you can comment on or make changes to this bug.