Closed Bug 685524 Opened 11 years ago Closed 8 months ago

reserve block of error codes in nspr for DNSSEC support

Categories

(NSPR :: NSPR, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rs, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.20) Gecko/20110816 Fedora/3.6.20-1.fc14 Firefox/3.6.20
Build ID: 20110816204636

Steps to reproduce:

create a patch for local dnssec validation of domain names


Actual results:

new error code are added, requiring patch to be updated periodically


Expected results:

we'd like to reserve a range of error codes in nsprpub/pr/include/prerr.h. e.g.

 +/* The DNS record failed DNSSEC validation */
+#define PR_DNSSEC_VALIDATION_ERROR               (-5924L)
+
+/* The DNS record failed DNSSEC validation */
+#define PR_DNSSEC_DNE_ERROR                      (-5923L)

and in netwerk/base/public/nsNetError.h

@@ -281,6 +281,12 @@
  * DNS specific error codes:
  */

+#define NS_ERROR_DNSSEC_VALIDATION_ERROR \
+    NS_ERROR_GENERATE_FAILURE(NS_ERROR_MODULE_NETWORK, 34)
+
+#define NS_ERROR_DNSSEC_DNE_ERROR \
+    NS_ERROR_GENERATE_FAILURE(NS_ERROR_MODULE_NETWORK, 35)


In both cases we're currently using 2 error codes, it would be nice if we could get a few extras reserved for future use too.. maybe 8-10?
Moving to NSPR, since that's where the code is.  

The basic idea sounds fine to me.
Assignee: nobody → wtc
Component: Networking → NSPR
Product: Core → NSPR
QA Contact: networking → nspr
Version: Trunk → other
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

The bug assignee didn't login in Bugzilla in the last 7 months.
:KaiE, could you have a look please?
For more information, please visit auto_nag documentation.

Assignee: wtc → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(kaie)

Please reopen if you really still need this 10 years later.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(kaie)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.