"Save As" dialog triggers a "Warning: Unresponsive script" / dialog moved behind the main window

UNCONFIRMED
Unassigned

Status

()

Core
General
UNCONFIRMED
6 years ago
4 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

With "focus follows mouse" of fvwm:
1. Rename the ".mozilla" directory to start with a fresh profile.
2. Start Firefox.
3. Select "File" → "Save Page As..." (the "Save As" dialog opens).
4. Move the mouse pointer to another area so that Firefox looses the focus, and move it back to the main window or "Save As" dialog after some time.
5. If nothing bad occurs, repeat step 4 (at least on my machine, this loop is finite).


Actual results:

The "Save As" window disappeared (in fact, it was moved behind the main window) and I got a dialog:

  Warning: Unresponsive script

  A script on this page may be busy, or it may have stopped responding.
  You can stop the script now, or you can continue to see if the script
  will complete.

  Script: resource:///modules/NetworkPrioritizer.jsm:175

  [ ] Don't ask me again

                                             [Stop script]  [Continue]

I could click, but then I had the impression that Firefox was completely frozen; but in fact the "Save As" dialog was behind the main window.


Expected results:

Nothing (no "Warning: Unresponsive script" dialog, and the "Save As" dialog should have remained where it was, but this latter problem may be a consequence of the former one).
(Reporter)

Comment 1

6 years ago
Note: other versions may be affected (5, 7, 8). I did other tests with Debian's Iceweasel:

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640926#26

There may be related bugs like bug 493578 or bug 482811, but note that this is under Linux here. If the bug is marked as a duplicate, please update the Platform field.
Works for me on Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1

Could you attempt to check that this issue reproduces on your side with a clean profile on the current Nightly with current or different steps? 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Bug 482811 is similar, but no comments were made recently and the issue might be fixed. We have to be sure that the issue is still reproducible on a Nightly before setting a resolution to the current bug.
(Reporter)

Comment 3

6 years ago
(In reply to Virgil Dicu [QA] from comment #2)
> Works for me on Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110908
> Firefox/9.0a1

I reproduced it easily with

Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110926 Firefox/9.0a1

on the about:home URL.

> Bug 482811 is similar, but no comments were made recently and the issue
> might be fixed. We have to be sure that the issue is still reproducible on a
> Nightly before setting a resolution to the current bug.

Bug 482811 is against Thunderbird, but both bugs might be the same one.
I'll set this as duplicate of Bug 482811, as comments are referring to Firefox behavior too. Please use that entry for comments regarding the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482811
(Reporter)

Comment 5

6 years ago
When a bug is marked as a duplicate, the Product/Component/Platform fields of the target bug may need to be updated. Here bug 482811 should have Product set to Core and Platform set to all/all.
(Reporter)

Comment 6

6 years ago
Reopened due to comment 86 of bug 482811. Since 482811 is blocked by a Mac-only bug (in Widget: Cocoa), this cannot be the same bug.

Also note that here Firefox doesn't really hang, even though under some conditions, if one isn't aware of this problem, it can appear as frozen because of the hidden dialog box.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1

Ok, at least we clarified that.

I was unsuccessful while trying to reproduce on Ubuntu 11.04.

1. Start Firefox with a clean profile.
2. Select File-Save Page As.
3. I moved the mouse pointer to another area on the page (while the Save As dialog was open).
4. Waited for 20 to 30 seconds.
5. Move the pointer and click on the Save as dialog window.

Anything else that you think could help me reproduce, Vincent? How much time you usually wait until the warning message is displayed?
(Reporter)

Comment 8

6 years ago
You may need to use some MouseFocus (a.k.a. FocusFollowsMouse) feature. When the warning dialog appears, it is always just after the mouse enters the main window or the "Save As" window (which has the effect to change the focus).

Also make sure you don't have any extension. I haven't been able to reproduce the bug with my normal profile (I don't know whether this is due to some extension or to the other tabs).

I'll try to reproduce it on another machine (with a very similar user configuration), just to make sure this isn't due to some obscure machine-specific reason.

Comment 9

4 years ago
Created attachment 757791 [details]
Screenshot double dialogues on MacOSX / FF21

I managed to have a similar behaviour on MacOS 10.6.8 ? FF 21

I can't tell whether the save dialogue triggered the unresponsive script window but the fact is that Save and Cancel buttons are irresponsive, the unresponsive window box is not selectable and ... none of the close window, tabs etc. do anything either.

I have quite a few extensions installed though, like firebug, ghostery, adblockplus, livehttpheaders, tabscounter, webdeveloper something...
You need to log in before you can comment on or make changes to this bug.