Closed Bug 685811 Opened 13 years ago Closed 12 years ago

Geolocation fails to call error callback when permission is denied

Categories

(Core :: DOM: Geolocation, defect)

6 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 675533

People

(Reporter: steveblock, Assigned: dougt)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.126 Safari/535.1

Steps to reproduce:

Visit http://dev.w3.org/geo/api/test-suite/t.html?00001 and follow instructions.


Actual results:

No callback made


Expected results:

Error callback should be called
Notes ...
- This test passed with Firefox 3.6 - http://www.w3.org/2008/geolocation/drafts/API/Implementation-Report.html
- If you select 'Not now' from the permission prompt, the test fails as described above, but if you select 'Never share', the test passes.
Component: General → Geolocation
Product: Firefox → Core
QA Contact: general → geolocation
Dupe of Bug 675533 (WONTFIXED)?
Assignee: nobody → doug.turner
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
jdm, in this case, we don't have a one-time "don't share" option.  it is either:

Share
Always Share
Always Deny
I was aware of the situation, but unaware that we had plans to change it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
So will a "Deny" option be added?
dolske, you made the changes to the door hanger.  what's the background here?
The doorhanger allows the user to change their mind at any point after having ignored the question (it sticks around as a little icon in the location bar), so we can't fire the error callback - the question is effectively pending indefinitely. If you select "Never", we do fire the error callback, as mentioned in comment 1.

I don't know why this was reopened, it looks like a duplicate of bug 675533 to me.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.