Closed Bug 68588 Opened 20 years ago Closed 20 years ago

view page source gives incorrect results for non-GET requests

Categories

(Core :: Networking: Cache, defect)

defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 55583

People

(Reporter: kennedyh, Assigned: neeti)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.6 sun4u; en-US; m18) Gecko/20010123
BuildID:    2001012321

view the page source for pages generated from POST requests
appears to return the result of a GET request against the
URL that was POSTed to.

i will do some tcpdumping to see what's really going on soon.

Reproducible: Always
Steps to Reproduce:
1. visit the above url
2. enter a bug number
3. click "Show"
4. the page submits the query to bugzilla, but via POST instead of GET.
5. when the results page shows up, select View->Page Source, or do a Ctrl+U

Actual Results:  shows the source of the base URL,
http://bugzilla.mozilla.org/show_bug.cgi



Expected Results:  show the source of the entry for the bug ID that was entered.

if this *is* actually making another hit to the network to fetch data,
then poorly-written server-side applications will receive the 
request a second time, and make take action on the user's behalf
that the user did not intend.
Duplicate of bug 55583. It is an old bug and should be fixed by mozilla1.0.
Thanks for your help!
Fabian.

*** This bug has been marked as a duplicate of 55583 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
so true.
that's what i get for searching for "view source" :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.