Last Comment Bug 686024 - Right-click on the active tab focuses the tab itself occasionally
: Right-click on the active tab focuses the tab itself occasionally
Status: RESOLVED FIXED
fixed by bug 682338; regression windo...
: regression
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: Firefox 9
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 682338
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-09 15:03 PDT by ithinc
Modified: 2011-09-27 12:00 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (47.04 KB, image/png)
2011-09-11 19:18 PDT, ithinc
no flags Details
graphics section from about:support (49.50 KB, image/png)
2011-09-11 19:21 PDT, ithinc
no flags Details

Description ithinc 2011-09-09 15:03:48 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

1. Right-click on the active tab, then click in the content area
2. Repeat step 1 for several times



Actual results:

The active tab itself is focused, showing the dotted line, but not always.


Expected results:

The dotted line should not appear. Bug 563591 or 679255 may be related.
Comment 1 Tim (fmdeveloper) 2011-09-09 20:32:30 PDT
WFM - Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909030839

You posted with 6.0.2 but marked this bug on trunk...on which does it occur?

Can you find the regression window? http://harthur.github.com/mozregression/
Comment 2 ithinc 2011-09-11 04:50:35 PDT
It's on trunk. I'm not familiar with how to find a regression window.
Comment 3 Tim (fmdeveloper) 2011-09-11 15:37:16 PDT
Please attach a screenshot showing the issue. I have been unable to reproduce the issue.

Please also confirm if the issue occurs if you start Firefox in Safe mode and also post the graphics section from about:support (not while in safe mode)
Comment 4 ithinc 2011-09-11 19:18:08 PDT
Created attachment 559809 [details]
screenshot

This is a screenshot from a brand-new profile. When switching to a new tab, right-click the active tab's favicon. If not reproduced, repeat clicking in the content area and right-clicking the active tab's favicon again.
Comment 5 ithinc 2011-09-11 19:21:45 PDT
Created attachment 559810 [details]
graphics section from about:support
Comment 6 ithinc 2011-09-11 19:27:25 PDT
If you hold the mouse for a while, you may find the dotted line appears when mouseup, almost at the same time as tab context menu pops up. It happens in both 8.0a2 and 9.0a1, but not in 6.0. I have no 7.0b installed.
Comment 7 Tim (fmdeveloper) 2011-09-11 19:49:58 PDT
1) You should update your graphics driver - the correct one looks to be http://support.amd.com/us/gpudownload/Pages/radeon-prer300-xp.aspx

2) Still unable to reproduce on my system

3) Your best bet at getting traction is to either find another user that can reproduce (ask in support or on IRC) or find the regression range. Instructions are at http://harthur.github.com/mozregression/ on how to find the regression range.
Comment 8 ithinc 2011-09-11 21:10:12 PDT
Thanks for your guide. I have traced it back to:

Last good nightly: 2011-07-02
First bad nightly: 2011-07-03

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=549e3276ed25&tochange=4e3b03de1fd3
Comment 9 ithinc 2011-09-11 21:46:28 PDT
Further in mozilla-inbound.

Last good nightly: 2011-06-30
First bad nightly: 2011-07-01

Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c2f48684b9f5&tochange=26ecb4d6c3d0
Comment 10 Dão Gottwald [:dao] 2011-09-12 05:03:08 PDT
(In reply to ithinc from comment #8)
(In reply to ithinc from comment #9)
Nothing in these ranges seems to stick out. I'm afraid someone will need to bisect this further by compiling Firefox.
Comment 11 ithinc 2011-09-13 22:07:27 PDT
Can you confirm this regression, Dao?
Comment 12 Dão Gottwald [:dao] 2011-09-14 08:13:08 PDT
I could reproduce this a few days ago on Windows XP, but now I can't.
Comment 13 ithinc 2011-09-27 11:54:38 PDT
It seems fixed in the trunk, probably by bug 682338.

Last good nightly: 2011-09-11
First bad nightly: 2011-09-12

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=06b2977afb85&tochange=569a45bfb71c

Note You need to log in before you can comment on or make changes to this bug.