XML entities are not rendered correctly in XHTML docs

VERIFIED DUPLICATE of bug 22942

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 22942
17 years ago
12 years ago

People

(Reporter: Sam Steingold, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd" [
  <!ENTITY % sds-ent SYSTEM "http://www.podval.org/~sds/sds-ent.xml">
  %sds-ent;
]>

"%sds-ent;" is rendered as is instead of causing the file to be loaded.

also, the entities defined in the file sds-ent.xml and used in this page are not
displayed correctly.
The server returns a content-type of text/html for this document.  Why should it
be treated as an xml document?

When I save it as data.xml, the external entities are still not loaded, but the
%sds-ent; is also not shown...

Comment 2

17 years ago
As per bug 22942, *external* entities are not resolved by default, except if
the file is placed in the local directory "bin/dtd" ..

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
vrfy dupe of bug 22942 Load external DTDs (local and remote) if a pref is set

however, bz is correct that the testcase itself would be invalid because it 
fails to return the correct dtd.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.