Firefox does not provide client-side decryption

RESOLVED DUPLICATE of bug 649154

Status

()

defect
RESOLVED DUPLICATE of bug 649154
8 years ago
8 years ago

People

(Reporter: t8av, Unassigned)

Tracking

6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I was trying to find browser decryption capability of firefox but I could not find it. Now-days there is a great need for users to store their private files on a remote server and view their files using the browser, however when a user upload his files to a remote server he/she wants the file to be encrypted. When viewing the file, the browser must decrypt the file on-the-fly and present it.
There's no standard for this, but ddahl is working on a proposal (DOMCrypt). This should probably be closed as a dupe of some existing bug.
See https://wiki.mozilla.org/Privacy/Features/DOMCryptAPISpec/Latest and bug 649154
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: domcrypt
You need to log in before you can comment on or make changes to this bug.