NS_NOINTERFACE in passwords engine on XUL Fennec

RESOLVED WONTFIX

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sync:xulfennec])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
1315861854722 Sync.Engine.Passwords WARN Got exception Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface] Stack trace: resource://services-sync/engines/passwords.js:119 < resource://gre/modules/XPCOMUtils.jsm:210 < applyIncomingBatch()@resource://services-sync/engines/passwords.js:167 < doApplyBatch()@resource://services-sync/engines.js:680 < resource://services-sync/ engines.js:787 < resource://services-sync/record.js:828 < Channel_onDataAvail()@resource://services-sync/resource.js:569, aborting processIncoming.


First sync on new Fennec profile. Error console output. No log (yet).

Comment 1

7 years ago
Created attachment 567108 [details]
Failed password sync log

Reproduced this on first fennec sync.  See log.
Device: Galaxy S II, Android 2.3.3
Using Nightly: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/201101014 Firefox/10.0a1 Fennec/10.0a1

Comment 2

7 years ago
(In reply to Tony Chung [:tchung] from comment #1)
> Created attachment 567108 [details]
> Failed password sync log
> 
> Reproduced this on first fennec sync.  See log.
> Device: Galaxy S II, Android 2.3.3
> Using Nightly: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1)
> Gecko/201101014 Firefox/10.0a1 Fennec/10.0a1

ugh, line break fail.   here's a pastebin version.  http://pastebin.mozilla.org/1355105
(Reporter)

Updated

7 years ago
Blocks: 696969
(Reporter)

Updated

6 years ago
Summary: NS_NOINTERFACE in passwords engine on Fennec → NS_NOINTERFACE in passwords engine on XUL Fennec
(Reporter)

Updated

5 years ago
Whiteboard: [sync:xulfennec]
(Reporter)

Updated

5 years ago
Duplicate of this bug: 678137
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.