Closed Bug 686396 Opened 8 years ago Closed 8 years ago

TI: Assertion failure: [infer failure] Missing type for this: bool, at jsinfer.cpp:341

Categories

(Core :: JavaScript Engine, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: decoder, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase, Whiteboard: js-triage-needed)

The following test crashes on jaegermonkey branch revision 0b9a541b2e0a (options -m -n -a):


(function () { 
  assertEquals = function assertEquals(expected, found, name_opt) {  };
})();
function testOne(receiver, key, result) {
  for(var i = 0; i != 10; i++ ) {
    assertEquals(result, receiver[key]());
  }
}
function TypeOfThis() { return typeof this; }
Number.prototype.type = TypeOfThis;
String.prototype.type = TypeOfThis;
Boolean.prototype.type = TypeOfThis;
testOne(2.3, 'type', 'object');
testOne('x', 'type', 'object');
testOne(true, 'type', 'object');
Retested on m-c, cannot reproduce there anymore so closing as WFM.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
A testcase for this bug was automatically identified at js/src/jit-test/tests/basic/bug686396.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.