Last Comment Bug 686405 - remove the debug button and just sleep for 5s
: remove the debug button and just sleep for 5s
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla10
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
: Jim Chen [:jchen] [:darchons]
Mentors:
Depends on:
Blocks: 704414
  Show dependency treegraph
 
Reported: 2011-09-12 21:09 PDT by Doug Turner (:dougt)
Modified: 2011-11-21 22:10 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (3.96 KB, patch)
2011-09-12 21:10 PDT, Doug Turner (:dougt)
snorp: review+
Details | Diff | Splinter Review
Bug 686405 - remove the debug button and just wait 5s for the debugger (4.12 KB, patch)
2011-10-03 09:02 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
doug.turner: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2011-09-12 21:09:29 PDT
with the newest jimdb (jim's gdb), you really don't need to press a button to continue.  Instead, we can just rip out the press-a-button-to-continue debug intent, and just turn that into a Thread.sleep().
Comment 1 Doug Turner (:dougt) 2011-09-12 21:10:40 PDT
Created attachment 559927 [details] [diff] [review]
patch v.1
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-09-12 21:13:04 PDT
Comment on attachment 559927 [details] [diff] [review]
patch v.1

Seems ok to me
Comment 4 Phil Ringnalda (:philor) 2011-09-12 23:30:36 PDT
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/3950656acf1b - I'm pretty sure that you completely broke every test suite (by either failing to start up, or crashing, dunno which), though it's pretty funny that I was able to star all the failures right up until I realized that you were at 18 of 23 jobs all failed, and the bug 686091 failures were looking a little odd, because they were taking a bit more than 15 seconds.
Comment 5 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-10-03 09:02:21 PDT
Created attachment 564209 [details] [diff] [review]
Bug 686405 - remove the debug button and just wait 5s for the debugger
Comment 6 Doug Turner (:dougt) 2011-10-03 11:49:00 PDT
snorp - do we need the enum WaitForDebugger?
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-10-03 11:55:49 PDT
(In reply to Doug Turner (:dougt) from comment #6)
> snorp - do we need the enum WaitForDebugger?

Yeah, we're running the Android main loop for that 5s so I think it's a good idea to have a state for this.
Comment 9 Ed Morley [:emorley] 2011-10-07 04:57:28 PDT
https://hg.mozilla.org/mozilla-central/rev/bb4562eb08c8

Note You need to log in before you can comment on or make changes to this bug.