Extra RTL style for search-bar auto-completion

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: ebrahim, Unassigned)

Tracking

({rtl, testcase})

9 Branch
x86
Windows 7
rtl, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 559928 [details]
firefoxautocompletion.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110905 Firefox/9.0a1
Build ID: 20110905040204

Steps to reproduce:

Hi, sometimes my Firefox shows auto completion of search-bar in RTL. I can not reproduce that always (or preform a testcase for it) but this serious because I saw this behavior also in other computer (but unfortunately, just sometimes!). I attached what I see sometimes in Firefox.
Bug 649840 have relation to this bug, specially this comment https://bugzilla.mozilla.org/show_bug.cgi?id=649840#c9 I think.

Thanks!

Comment 1

7 years ago
Hmm, your search button looks weird (it has text on it, and no icon.  Can you try to reproduce this bug in safe mode? <http://support.mozilla.com/en-US/kb/Safe%20Mode>
Component: General → Search
QA Contact: general → search
(Reporter)

Comment 2

7 years ago
Because I am using nightly-ux instead of standard version of Firefox, but I saw this problem on other systems outside of my home! :) (of-course, with standard version of Firefox)
Sorry, I have not more information about this because it is not enough reproducible and I don't know why sometimes I see that! :)

Comment 3

7 years ago
Anas, is this something that you would like to work on?
Sure. I'll try if I can reproduce it first.
(Reporter)

Comment 5

7 years ago
Created attachment 568358 [details]
Extra RTL Style on autocomplete

The bug is available till now but I don't how to reproduce it always.

Comment 6

7 years ago
I quite often experience this bug as well on stock Firefox on Ubuntu. This has been happening for a while, possibly since Firefox 4. I have not been able to figure out the steps to reproduce it, but my initial guess is that these could be contributing factors:
(1) conducting a search in an RTL language – I routinely search in Hebrew,
(2) and/or having one of the BiDi preferences different from the default – I have bidi.browser.ui, bidi.edit.caret_movement_style (set to 0), and bidi.edit.delete_immediately all modified.

ebraminio, do you have any of those factors?
(Reporter)

Comment 7

7 years ago
Hi,
1) Yes
2) bidi.browser.ui and bidi.edit.delete_immediately
but I am not sure about second, where I saw that on my friend Firefox that I don't think he modified that preferences.
Thanks
(Reporter)

Comment 8

5 years ago
You may won't believe but I saw two or three day ago on recent Firefox on ArchLinux without any configuration (I don't use Firefox as my default browser so I didn't change any Firefox setting)
(Reporter)

Comment 9

5 years ago
Created attachment 761581 [details]
Bug686406OnFF21KDE

Proof! I saw it first time on Awesome WM so it is not related to KDE. I don't even use Firefox synching or any manual modification on about:config. Only way I think it could be reproduced is surfing RTL pages like Persian wikipedia or umm, I don't know :)
(Reporter)

Comment 10

5 years ago
I even see it in another two PC today.

Comment 11

5 years ago
With help from Ebrahim I managed to reproduce it consistently.

1. Use Firefox with LTR user interface, for example English.

2. Use this data URL:
data:text/html, <html dir="rtl"><body><form><input type="text" name="text1" value="" autocomplete="on"/></form></body></html>

3. Write "asdf" in the input box.

4. Press Enter.

5. Click the input box twice to see the auto-completion of "asdf".

6. Write "asdf" in the search bar.

What I see: the auto-suggestions are on the right side.

What I expect: the auto-suggestions are supposed to be on the left side.

Updated

5 years ago
Component: Search → Autocomplete
Keywords: rtl, testcase
Product: Firefox → Toolkit
(Reporter)

Comment 12

5 years ago
This is still available even on latest UX version.
(Reporter)

Comment 13

3 years ago
Good news, this no longer exists somehow; probably due some rewrite done on search bar autocomplete popup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.