Browser doesn't start, because of Ontrack's SystemSuite 3.0 Task Manager

RESOLVED DUPLICATE of bug 53952

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 53952
17 years ago
12 years ago

People

(Reporter: Rick DeBay, Assigned: asa)

Tracking

({relnote})

Trunk
x86
Windows NT
relnote

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (WinNT; U)
BuildID:    20010109

Neither browser nor Profile Manager will start.  Mozilla.exe is in
the task list with no CPU activity and 1932K memory in use.
It can be killed from the task list.  No splash screen is displayed.

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla from desktop, command prompt, etc.
2.
3.

This also happens with Netscape 6.01.  Since 6.0 is no longer
available, I can't test that.  NS 4.75 is fine.
Could you please try a more recent build than 2001-01-09?

Also, do you have write permission to the Mozilla install directory?
(Reporter)

Comment 2

17 years ago
Yes, I have write permissions for the directory I installed Mozilla in :-)
The February 13 2001 build has the same problem.
BTW, the FAQ suggestion of mozilla.exe -installer didn't help.
The only change is that 2100K of memory is now consistently used.

Comment 3

17 years ago
I had this same problem in Linux with build 2001021303, but after deleting my
.mozilla directory, it runs fine.
(Assignee)

Comment 4

17 years ago
rick, try running mozilla -profilemanager and create a new profile.  if this
does not work please reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
mozilla -profilemanager didn't work.  I have the feeling that it's waiting
for something during initialization, since it stops with very little memory
in use.  At what point does it try to start the Java environment?
Something makes me think that could be it.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

17 years ago
please search for the bugs where i mention depends.exe and visit 
http://dependencywalker.com to get it.
(Reporter)

Comment 7

17 years ago
Created attachment 25303 [details]
depend.exe output
(Reporter)

Comment 8

17 years ago
Ran depend.exe - I don't know why user32.dll is missing an API,
it doesn't appear to be back level.
VC++ help says this is a Windows 2000/98 only API.

Comment 9

17 years ago
that's probably multiple monitor support. attached output is totally useless 
:-(

let's try filemon from sysinternals.com [and also see if checking all options 
in depends gives you better output -- doubtful :-( ]
(Reporter)

Comment 10

17 years ago
Holy cr*p it works!  I killed all processes for Microsoft SMS and McAfee
VirusScan 4.5 and Mozilla starts.  I'll try to narrow it down.
(Reporter)

Comment 11

17 years ago
OK, the culprit was Ontrack's SystemSuite 3.0 Task Manager service.
I have no idea why it would keep Mozilla from running.  I'll
report it and see if they can come up with an answer.
Where does conflicts with software get recorded?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Summary: Browser doesn't start, leaving dead process in task list → Browser doesn't start, because of Ontrack's SystemSuite 3.0 Task Manager
(Reporter)

Comment 12

17 years ago
It doesn't look like Ontrack is going to do anything about this.
I don't know if it's their bug, or Mozilla's.
Severity: critical → normal
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 13

17 years ago
The email rickd@thebox.com is no longer valid.  I can be reached at
casper@gate.net or rdebay@iisystems.com; I couldn't find any way to
change the reporter.
If I a copy of the software is needed to reproduce the problem I
can supply it, as long as there are no licensing issues.
I'm still trying to convince Ontrack to download Mozilla and reproduce
it themselves.

Comment 14

17 years ago
Hmmmm possibly a relnote here? Thoughts?

Updated

17 years ago
Keywords: relnote

Comment 15

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 16

17 years ago
CCing endico for possible release note comment.

Comment 17

17 years ago
I can confirm exactly the same problem with 0.8.1 and SystemSuite 3.0 on 
NT4/SP6.

I doubt very much that its a SystemSuite problem since:

1) I have hundreds of other applications which work OK with the SystemSuite 
service present/started.

2) There are other bug reports relating to non-starting with various other 
things running.

I think its something to do with Mozilla's startup sequence, perhaps where it 
tries to DDE with possible previous instances of itself. 

I think this one is IMPORTANT!.

Cheers,
Chris
DDE could very well be the problem... see bug 53952
Depends on: 53952
reading 53952 more carefully, this is a duplicate.

*** This bug has been marked as a duplicate of 53952 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
No longer depends on: 53952
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.