Status

RESOLVED INVALID
7 years ago
9 months ago

People

(Reporter: m_kato, Assigned: m_kato, NeedInfo)

Tracking

(Depends on: 1 bug)

Trunk
ARM
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
Windows 8 and VS11 support arm target, I would like to add arm target for experiment.
(Assignee)

Updated

7 years ago
Depends on: 687033
Interesting. Is this different from Windows CE?
(In reply to Ted Mielczarek [:ted, :luser] from comment #1)
> Interesting. Is this different from Windows CE?

This is presumably to support Windows 8 on ARM devices. This will require MSVC 2011 support, so adding that as a blocker.
Depends on: 686837
(Assignee)

Comment 3

7 years ago
(In reply to Ted Mielczarek [:ted, :luser] from comment #1)
> Interesting. Is this different from Windows CE?

- ABI seems to be different.  double must be 8 bytes alignment.
- ARMv7 + thumb2 by default.  No option to use ARMv6
Blocks: 687213
Depends on: 712841
No longer depends on: 712841
MS is only allowing Metro apps on ARM at this point so I'm marking this as invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Maybe it's time to reconsider this for Windows 10 since it's launching to device like Raspberry Pi 2 ?
It depends on whether Microsoft has changed their stance on the issue raised in comment 4.
(Assignee)

Updated

10 months ago
Duplicate of this bug: 1439202

Comment 8

10 months ago
Please support "Wine for Android"(compatibility layer) in AMR device.
Flags: needinfo?(netzen)

Comment 9

9 months ago
Windows 10 on ARM?
Flags: needinfo?(m_kato)
(Assignee)

Comment 10

9 months ago
(In reply to In from comment #9)
> Windows 10 on ARM?

If we start to develop it, we (I?) will create meta bug for our work items.  So I don't know current plan and we shouldn't reopen this at this time.

Also, When WinRT age, I had a lot of patch set for jailbreak'ed WinRT...
Flags: needinfo?(m_kato)
(Assignee)

Comment 11

9 months ago
And as long as I know, Microsoft is testing for Firefox on WoA on x86 emulation.  And even if we port Firefox to aarch64, we don't have IonJIT compiler for aarch64, so Firefox x86 will faster than Firefox aarch64.

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.