Tab is closed when tapping near the "X" button

VERIFIED FIXED in Firefox 9

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Andreea Pod, Assigned: lucasr)

Tracking

Trunk
Firefox 9
ARM
Android

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Mozilla /5.0 (Android;Linux armv7l;rv:9.0a1) Gecko/20110914 Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire Z (Android 2.3)

Steps to reproduce:
1. Open a few tabs
2. Go to tab panel
3. tap on a tab between the middle of the tab and the X button

Expected results:
nothing should happen if the tab is in focus, if not it should get in focus

Actual result:
the tab is closed, please see the video: http://www.screencast.com/users/AndreeaDiana/folders/Jing/media/5018c266-0b1b-42d9-90ce-199c3cb4dd53

Note: 
- this is happening only on Android 2.3
- I made the video using DeviceAnywhere because using the real device would not be so clear that the click is not performed on the "X" button.
This is probably by design as they have a large 'hit' zone.

Updated

6 years ago
Summary: Tab is closed when taping near the "X" button → Tab is closed when tapping near the "X" button
This is far too easy to hit, currently. The 'hit' zone of the close button is for the phone UI at least, far too great, now. Tapping in the middle of the thumbnail even cause the tab to be closed.
tracking-firefox9: --- → ?
Assignee: nobody → lucasr.at.mozilla
(Assignee)

Comment 3

6 years ago
Created attachment 560495 [details] [diff] [review]
Make clickable area match close button boundaries
Attachment #560495 - Flags: review?(mark.finkle)
Attachment #560495 - Flags: review?(mark.finkle) → review+
Keywords: checkin-needed

Comment 4

6 years ago
Didn't apply cleanly, but fixed locally and pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c97a4d89f91
Status: NEW → ASSIGNED
Keywords: checkin-needed
Target Milestone: --- → Firefox 9
https://hg.mozilla.org/mozilla-central/rev/1c97a4d89f91
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110919 Firefox/9.0a1 Fennec/9.0a1
Status: RESOLVED → VERIFIED
tracking-fennec: --- → 9+
tracking-firefox9: ? → ---
status-firefox9: --- → fixed
You need to log in before you can comment on or make changes to this bug.