crash on unsubscribe from newsgroup (probably from corrupt .msf files)

VERIFIED DUPLICATE of bug 65838

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 65838
17 years ago
10 years ago

People

(Reporter: Mack Earnhardt, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (WinNT; U)
BuildID:    Mozilla0.8 custom pulled ~9:30am EST

I right-clicked in the left-hand pain on the newsgroup I was viewing and chose 
unsubscribe. Mozilla crashed with 'Unhandled exception in mozilla.exe (MORK.DLL) 
0xC0000005: Access Violation. I don't remember whether I got a confirmation 
message or not.

Reproducible: Sometimes
Steps to Reproduce:
Unsubcribe from newsgroup.

Actual Results:  Sometimes crashes.

Expected Results:  Unsubscribe.

morkRowObject::CloseRowObject(morkEnv * 0x06f84e00) line 110 + 3 bytes
morkRowObject::CloseMorkNode(morkEnv * 0x06f84e00) line 63
morkNode::cut_use_count(morkEnv * 0x06f84e00) line 535
morkNode::CutStrongRef(morkEnv * 0x06f84e00) line 551 + 12 bytes
morkNode::SlotStrongNode(morkNode * 0x00000000, morkEnv * 0x06f84e00, morkNode * 
* 0x06eb5e20) line 447
morkObject::SlotStrongObject(morkObject * 0x00000000, morkEnv * 0x06f84e00, 
morkObject * * 0x06eb5e20) line 100 + 20 bytes
morkHandle::CloseHandle(morkEnv * 0x06f84e00) line 117 + 18 bytes
morkHandle::CloseMorkNode(morkEnv * 0x06f84e00) line 59
morkNode::cut_use_count(morkEnv * 0x06f84e00) line 535
morkNode::CutStrongRef(morkEnv * 0x06f84e00) line 551 + 12 bytes
morkHandle::Handle_CutStrongRef(nsIMdbEnv * 0x06f5b828) line 395
orkinRow::CutStrongRef(nsIMdbEnv * 0x06f5b828) line 267
nsMsgHdr::~nsMsgHdr() line 134
nsMsgHdr::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsMsgHdr::Release(nsMsgHdr * const 0x060d5620) line 33 + 154 bytes
nsCOMPtr<nsIMsgDBHdr>::~nsCOMPtr<nsIMsgDBHdr>() line 489
nsMessage::~nsMessage() line 46 + 22 bytes
nsMessage::`scalar deleting destructor'(unsigned int 1) + 16 bytes
nsRDFResource::Release(nsRDFResource * const 0x07640030) line 68 + 129 bytes
nsMessage::Release(nsMessage * const 0x07640030) line 49 + 12 bytes
Value::Clear() line 189 + 27 bytes
Value::~Value() line 178
nsAssignment::~nsAssignment() line 335 + 44 bytes
nsAssignmentSet::List::~List() line 372 + 44 bytes
nsAssignmentSet::List::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsAssignmentSet::List::Release() line 378 + 34 bytes
nsAssignmentSet::List::~List() line 372 + 20 bytes
nsAssignmentSet::List::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsAssignmentSet::List::Release() line 378 + 34 bytes
nsAssignmentSet::~nsAssignmentSet() line 406 + 18 bytes
Instantiation::~Instantiation() line 558 + 52 bytes
Match::~Match() line 442 + 66 bytes
Match::`scalar deleting destructor'(unsigned int 1) + 15 bytes
Match::Release() line 438 + 34 bytes
MatchSet::Erase(MatchSet::Iterator {...}) line 1185
MatchSet::Clear() line 1112 + 35 bytes
MatchSet::~MatchSet() line 1050
ConflictSet::BindingEntry::~BindingEntry() line 1689 + 44 bytes
ConflictSet::BindingEntry::`scalar deleting destructor'(unsigned int 1) + 15 
bytes
ConflictSet::FreeBindingEntry(void * 0x056a4d2c, PLHashEntry * 0x07641c38, 
unsigned int 1) line 1719 + 28 bytes
PL_HashTableDestroy(PLHashTable * 0x06eb0b40) line 150 + 16 bytes
ConflictSet::Destroy() line 1798 + 12 bytes
ConflictSet::Clear() line 2035
nsXULTemplateBuilder::RebuildContainerInternal(nsIContent * 0x05d10170, int 0) 
line 4482
nsXULTemplateBuilder::RebuildContainer(nsXULTemplateBuilder * const 0x056a4b34, 
nsIContent * 0x05d10170) line 4463 + 17 bytes
nsXULDocument::RebuildWidgetItem(nsIContent * 0x05d10170) line 4484 + 22 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x03efe700, nsIContent * 
0x05d10170, int 0, nsIAtom * 0x019b3250, int -1) line 1671
nsXULElement::SetAttribute(nsXULElement * const 0x05d10170, nsINodeInfo * 
0x05e7f720, const basic_nsAReadableString<unsigned short> & {...}, int 1) line 
2906
nsXULElement::SetAttribute(nsXULElement * const 0x05d10174, const 
basic_nsAReadableString<unsigned short> & {...}, const 
basic_nsAReadableString<unsigned short> & {...}) line 1306 + 31 bytes
nsXULTreeElement::SetAttribute(nsXULTreeElement * const 0x0652cb78, const 
basic_nsAReadableString<unsigned short> & {...}, const 
basic_nsAReadableString<unsigned short> & {...}) line 54 + 29 bytes
ElementSetAttribute(JSContext * 0x04ffc8c0, JSObject * 0x02e40878, unsigned int 
2, long * 0x059dd7b0, long * 0x0012b818) line 249 + 26 bytes
js_Invoke(JSContext * 0x04ffc8c0, unsigned int 2, unsigned int 0) line 777 + 23 
bytes
js_Interpret(JSContext * 0x04ffc8c0, long * 0x0012c5c4) line 2670 + 15 bytes
js_Invoke(JSContext * 0x04ffc8c0, unsigned int 1, unsigned int 2) line 794 + 13 
bytes
js_InternalInvoke(JSContext * 0x04ffc8c0, JSObject * 0x02e40770, long 93156760, 
unsigned int 0, unsigned int 1, long * 0x0012c75c, long * 0x0012c6ec) line 866 + 
20 bytes
JS_CallFunctionValue(JSContext * 0x04ffc8c0, JSObject * 0x02e40770, long 
93156760, unsigned int 1, long * 0x0012c75c, long * 0x0012c6ec) line 3271 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x04f860a0, void * 0x02e40770, 
void * 0x058d7598, unsigned int 1, void * 0x0012c75c, int * 0x0012c758, int 0) 
line 934 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x0763b8b4) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x064bf9f0, 
nsIDOMEvent * 0x0763b8b4, nsIDOMEventTarget * 0x05d10ab8, unsigned int 8, 
unsigned int 7) line 838 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x056e1b50, nsEvent * 
0x0012d004, nsIDOMEvent * * 0x0012cf94, nsIDOMEventTarget * 0x05d10ab8, unsigned 
int 7, nsEventStatus * 0x0012d028) line 1343 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05d10ab0, nsIPresContext * 
0x056e1b50, nsEvent * 0x0012d004, nsIDOMEvent * * 0x0012cf94, unsigned int 1, 
nsEventStatus * 0x0012d028) line 3455
nsXULTreeElement::FireOnSelectHandler(nsXULTreeElement * const 0x0652412c) line 
455
nsXULElement::RemoveChildAt(nsXULElement * const 0x0694c050, int 7, int 1) line 
2647
nsXULTemplateBuilder::RemoveMember(nsIContent * 0x064bc1a0, nsIRDFResource * 
0x02a20040, int 1) line 6094 + 40 bytes
nsXULTemplateBuilder::Retract(nsIRDFResource * 0x02a1f4c0, nsIRDFResource * 
0x029fb660, nsIRDFNode * 0x02a20040) line 4774
nsXULTemplateBuilder::OnUnassert(nsXULTemplateBuilder * const 0x056bc8a8, 
nsIRDFDataSource * 0x056ba790, nsIRDFResource * 0x02a1f4c0, nsIRDFResource * 
0x029fb660, nsIRDFNode * 0x02a20040) line 4816 + 23 bytes
CompositeDataSourceImpl::OnUnassert(CompositeDataSourceImpl * const 0x056ba794, 
nsIRDFDataSource * 0x06152890, nsIRDFResource * 0x02a1f4c0, nsIRDFResource * 
0x029fb660, nsIRDFNode * 0x02a20040) line 1484
nsMsgRDFDataSource::unassertEnumFunc(nsISupports * 0x056ba794, void * 
0x0012d670) line 454
nsSupportsArray::EnumerateForwards(nsSupportsArray * const 0x06152830, int 
(nsISupports *, void *)* 0x05dce950 
nsMsgRDFDataSource::unassertEnumFunc(nsISupports *, void *), void * 0x0012d670) 
line 357 + 20 bytes
nsMsgRDFDataSource::NotifyObservers(nsIRDFResource * 0x02a1f4c0, nsIRDFResource 
* 0x029fb660, nsIRDFNode * 0x02a20040, int 0, int 0) line 428
nsMsgFolderDataSource::OnItemAddedOrRemoved(nsISupports * 0x02a1f4c0, 
nsISupports * 0x02a20040, const char * 0x02b89a0c, int 0) line 758
nsMsgFolderDataSource::OnItemRemoved(nsMsgFolderDataSource * const 0x061528c0, 
nsISupports * 0x02a1f4c0, nsISupports * 0x02a20040, const char * 0x02b89a0c) 
line 729
nsMsgMailSession::OnItemRemoved(nsMsgMailSession * const 0x0614d1b4, nsISupports 
* 0x02a1f4c0, nsISupports * 0x02a20040, const char * 0x02b89a0c) line 276
nsMsgFolder::NotifyItemDeleted(nsMsgFolder * const 0x02a1f4dc, nsISupports * 
0x02a1f4c0, nsISupports * 0x02a20040, const char * 0x02b89a0c) line 2372
nsMsgFolder::PropagateDelete(nsMsgFolder * const 0x02a1f4dc, nsIMsgFolder * 
0x02a2005c, int 1) line 1103
nsNntpIncomingServer::Unsubscribe(nsNntpIncomingServer * const 0x0654c8c8, const 
unsigned short * 0x0763ab80) line 1189 + 46 bytes
XPTC_InvokeByIndex(nsISupports * 0x0654c8c8, unsigned int 13, unsigned int 1, 
nsXPTCVariant * 0x0012da68) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x04ffc8c0, 
nsXPCWrappedNative * 0x076388b0, const XPCNativeMemberDescriptor * 0x0763811c, 
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 1, long * 
0x059dd684, long * 0x0012dc50) line 920 + 42 bytes
WrappedNative_CallMethod(JSContext * 0x04ffc8c0, JSObject * 0x02e40060, unsigned 
int 1, long * 0x059dd684, long * 0x0012dc50) line 250 + 34 bytes
js_Invoke(JSContext * 0x04ffc8c0, unsigned int 1, unsigned int 0) line 777 + 23 
bytes
js_Interpret(JSContext * 0x04ffc8c0, long * 0x0012e9fc) line 2670 + 15 bytes
js_Invoke(JSContext * 0x04ffc8c0, unsigned int 1, unsigned int 2) line 794 + 13 
bytes
js_InternalInvoke(JSContext * 0x04ffc8c0, JSObject * 0x05889fc0, long 92839960, 
unsigned int 0, unsigned int 1, long * 0x0012eb94, long * 0x0012eb24) line 866 + 
20 bytes
JS_CallFunctionValue(JSContext * 0x04ffc8c0, JSObject * 0x05889fc0, long 
92839960, unsigned int 1, long * 0x0012eb94, long * 0x0012eb24) line 3271 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x04f860a0, void * 0x05889fc0, 
void * 0x0588a018, unsigned int 1, void * 0x0012eb94, int * 0x0012eb90, int 0) 
line 934 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x07693e14) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x06006320, 
nsIDOMEvent * 0x07693e14, nsIDOMEventTarget * 0x05f1e508, unsigned int 8, 
unsigned int 7) line 838 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x056e1b50, nsEvent * 
0x0012f44c, nsIDOMEvent * * 0x0012f3cc, nsIDOMEventTarget * 0x05f1e508, unsigned 
int 7, nsEventStatus * 0x0012f494) line 1720 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05f1e500, nsIPresContext * 
0x056e1b50, nsEvent * 0x0012f44c, nsIDOMEvent * * 0x0012f3cc, unsigned int 1, 
nsEventStatus * 0x0012f494) line 3455
PresShell::HandleDOMEventWithTarget(PresShell * const 0x056e2be0, nsIContent * 
0x05f1e500, nsEvent * 0x0012f44c, nsEventStatus * 0x0012f494) line 4961 + 39 
bytes
nsMenuFrame::Execute() line 1389
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x059dc7f0, nsIPresContext * 
0x056e1b50, nsGUIEvent * 0x0012f894, nsEventStatus * 0x0012f788) line 378
PresShell::HandleEventInternal(nsEvent * 0x0012f894, nsIView * 0x07660ec0, 
unsigned int 1, nsEventStatus * 0x0012f788) line 4929 + 41 bytes
PresShell::HandleEvent(PresShell * const 0x056e2be4, nsIView * 0x07660ec0, 
nsGUIEvent * 0x0012f894, nsEventStatus * 0x0012f788, int 0, int & 1) line 4849 + 
25 bytes
nsView::HandleEvent(nsView * const 0x07660ec0, nsGUIEvent * 0x0012f894, unsigned 
int 8, nsEventStatus * 0x0012f788, int 0, int & 1) line 372
nsView::HandleEvent(nsView * const 0x0768ce90, nsGUIEvent * 0x0012f894, unsigned 
int 8, nsEventStatus * 0x0012f788, int 0, int & 1) line 345
nsView::HandleEvent(nsView * const 0x075d71e0, nsGUIEvent * 0x0012f894, unsigned 
int 8, nsEventStatus * 0x0012f788, int 0, int & 1) line 345
nsView::HandleEvent(nsView * const 0x056e1360, nsGUIEvent * 0x0012f894, unsigned 
int 28, nsEventStatus * 0x0012f788, int 1, int & 1) line 345
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x056e1590, nsGUIEvent * 
0x0012f894, nsEventStatus * 0x0012f788) line 1424
HandleEvent(nsGUIEvent * 0x0012f894) line 68
nsWindow::DispatchEvent(nsWindow * const 0x0768cd54, nsGUIEvent * 0x0012f894, 
nsEventStatus & nsEventStatus_eIgnore) line 687 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f894) line 708
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 3949 + 
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 
4159
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 3080215, long * 
0x0012fc48) line 2966 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x024504b6, unsigned int 514, unsigned int 0, long 
3080215) line 923 + 27 bytes
USER32! 77e71820()
matchRENodes(MatchState *, RENode *, RENode *, const unsigned short *) line 1822 
+ 3 bytes

Updated

17 years ago
QA Contact: esther → stephend
(Reporter)

Comment 1

17 years ago
After stopping the debugger and restarting, I see that the newsgroup is not gone 
from the list. On clicking it, I get the windows for downloading more than 500 
headers. Now I was current within 15 minutes or so when I crashed, so I'm 
guessing the msf was gone.  After downloading, the messages marked as new were 
only the recent ones, so the rc file still had my info.
Can you give me the server and the newsgroup that you unsubscribed from?  When
you crashed, were you downloading newsgroups from any other server?
(Reporter)

Comment 3

17 years ago
It was n.p.m.porkjockeys from news.mozilla.org, and that was the only activity
at the time.
Confirming. I saw a crash with 2001021304, but it wasn't on unsubscribing proper
(and this isn't 100% reproduceable, but obviously, it's a problem.  I'll attach
a stack trace.  It's in our MORK database, CC:ing David Bienvenu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 25179 [details]
Stack trace of Talkback ID: TB26260883Z
I've seen this before. I think it was caused by a corrupt .msf file. look at
your .msf files, and look for non ascii data. it is possible to corrupt .msf
files by using two instances of mozilla (or a mozilla based application, like
Netscape 6) at the same time. I might be able to bulletproof to prevent crash
upon corruption, and perhaps get fancy and remove corrupt .msf files if I can
tell they are corrupt.
Status: NEW → ASSIGNED
Summary: crash on unsubscribe from newsgroup → crash on unsubscribe from newsgroup (probably from corrupt .msf files)
Oops, this is a DUP.  I'll find it and mark it so. Sorry, David.
This is a DUP of bug 65838 (same stack) MorkRowObject.

*** This bug has been marked as a duplicate of 65838 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
VERIFIED DUP.  I'll put Seth's comments in the older bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.